1.2. What's new since the last release

In 11.3 release, --enable-default-pie and --enable-default-ssp are enabled for GCC. They can mitigate some type of malicious attacks but they cannot provide a full protection. In case if you are reading a programming textbook, you may need to disable PIE and SSP with GCC options -fno-pie -no-pie -fno-stack-protection because some textbooks assume they were disabled by default.

Below is a list of package updates made since the previous release of the book.

Upgraded to:

Added:

Removed: