LFS FAQ Updates

Chris Staub chris at beaker67.com
Tue Jan 17 22:18:47 PST 2006


Here's a patch to update the LFS FAQ, mainly by removing old entries. I 
also have a few questions about some other FAQs...

"./configure: bad interpreter: Permission denied
      You're most likely getting this while building bash in Chapter 5 of
the LFS Book. The problem is most likely your mount options. You
probably have a line in /etc/fstab like:
      /dev/hda10 /mnt/lfs ext2 user 1 2..."

I don't know if this issue is still valid or not. Is bash specifically 
mentioned simply because it used to be the 1st package compiled and 
that's where this issue would come up?

"checking whether we are using GNU C... no"

I'm sure this is likely still a valid issue, but the FAQ entry refers to 
checking and making sure /tools/bin/grep is statically linked, which of 
course it shouldn't be anyway in LFS > 5.0. Does this one just need to 
be updated?

"Perl fails with *** missing separator. Stop."

This refers to MAKEDEV, which should of course be replaced with "udev".
Then again, this question could probably just be removed - I just tried
building perl after removing /dev/null, and the configure quit with
"/dev/null: Permission denied", not the error message mentioned in that
FAQ entry.

Glibc: "ld.map: No such file or directory".

This refers to the creation of /dev/null in glibc instructions, which is
no longer accurate. It also mentions a "mount --bind /dev $LFS/dev"
command which isn't used either. Also, I just tried running configure on
glibc after removing /dev/null - again, it just says "/dev/null:
Permission denied".
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: lfs-faq-updates.patch
URL: <http://lists.linuxfromscratch.org/pipermail/website/attachments/20060118/aee16d0d/attachment.ksh>


More information about the website mailing list