LFS FAQ Updates

Justin R. Knierim justin at knierim.org
Tue Feb 21 23:08:50 PST 2006


Chris Staub wrote:

Late I know, but thank you for your efforts Chris.  I had this in my 
inbox the last month and just now applied the patch since no one else 
beat me to it.  :)

> "./configure: bad interpreter: Permission denied
>      You're most likely getting this while building bash in Chapter 5 of
> the LFS Book. The problem is most likely your mount options. You
> probably have a line in /etc/fstab like:
>      /dev/hda10 /mnt/lfs ext2 user 1 2..."
> 
> I don't know if this issue is still valid or not. Is bash specifically 
> mentioned simply because it used to be the 1st package compiled and 
> that's where this issue would come up?

Could very well be.  It could be from the times when SBU was still bash 
units.  I haven't heard this one ever so don't know how frequent it 
really is...

> "checking whether we are using GNU C... no"
> 
> I'm sure this is likely still a valid issue, but the FAQ entry refers to 
> checking and making sure /tools/bin/grep is statically linked, which of 
> course it shouldn't be anyway in LFS > 5.0. Does this one just need to 
> be updated?

Yeah, if it is still relevant, then it should be updated IMO.

> "Perl fails with *** missing separator. Stop."
> 
> This refers to MAKEDEV, which should of course be replaced with "udev".
> Then again, this question could probably just be removed - I just tried
> building perl after removing /dev/null, and the configure quit with
> "/dev/null: Permission denied", not the error message mentioned in that
> FAQ entry.

Yeah, can be removed IMO.  The error message that you described is 
plenty obvious and the user should be able to figure it out.

> Glibc: "ld.map: No such file or directory".
> 
> This refers to the creation of /dev/null in glibc instructions, which is
> no longer accurate. It also mentions a "mount --bind /dev $LFS/dev"
> command which isn't used either. Also, I just tried running configure on
> glibc after removing /dev/null - again, it just says "/dev/null:
> Permission denied".

Yeah, also remove if it isn't valid anymore.  I know we don't do mount 
--bind's anymore so it is definately old.

Thanks again Chris.  Do you want to upgrade these?  Otherwise I can try 
to get to them when I have time.

Justin



More information about the website mailing list