splice error

Anderson Lizardo lizardo at linuxfromscratch.org
Sun Dec 12 10:37:09 PST 2004


On Friday 10 December 2004 03:14, Archaic wrote:
> Jeremy, I have tried with no luck to get rig of that splice error from
> the manage_news.pl script. I don't grok perl, but Anderson did comment
> in the script that something was a kludge. Perhaps he can shed some
> light on it. I've even copied lfs's news-2004.txt to the hlfs dir and
> still I get the errors.

It's fixed now. Actually, that "FIXME" comment is regarding the 
"dummy_section" hack. The splice warning happenend because the number of news 
items is lower the than $show_content + $show_link, so it tried to "splice" 
things beyond the array size. It was just a warning anyway, so it should not 
have broken anything.

-- 
Anderson Lizardo
lizardo at linuxfromscratch.org
http://www.linuxfromscratch.org/



More information about the website mailing list