pcmcia modem support in livecd-x86-6.2-pre3

Alexander E. Patrakov patrakov at ums.usu.ru
Wed Apr 12 06:39:25 PDT 2006


Howard wrote:

> Ah ... so there IS present a   serial_cs   available in sources to build 
> into a module.  cool!
> I thought it may have to be provided by the pcmcia-cs utility  but maybe 
> was not needed in the  >2.6.13  kernel.

The module is present in all 2.6 kernels. We just forgot to build it.

> You didn't say, are you still using 2.6.12  in   6.2-pre4 CD ?  or going 
> to the 2.6.16.

I am still not sure. The udev_update branch in the book uses linux-2.6.16. The 
LiveCD development is also done in two branches. So, if the 6.2-pre4 CD is 
released after the udev_update merge (which is likely to happen very soon), it 
will contain linux-2.6.16. If not, 2.6.12.5 (because old udev doesn't understand 
nested device classes necessary for input support for linux >= 2.6.15).

Anyway, a 2.6.16 based CD does exist, it is just not officially released: 
svn://svn.linuxfromscratch.org/livecd/branches/udev_update/ (you have to build 
it yourself).

-- 
Alexander E. Patrakov



More information about the livecd mailing list