Openssh-4.2p1 - can't login, doesn't ask for a password

Alexander E. Patrakov patrakov at ums.usu.ru
Fri Sep 30 07:09:59 PDT 2005


Michael Løjtnant wrote:
> Hi,
> 
> After successfully using the ALFS on the LiveCD to install a LFS system, 
> i'm trying to install the SSH-Daemon - but I can't.
> 
> I have installed the OpenSSL-0.9.8 with:
> 
> ./config --prefix=/usr/local
> 
> Then I install OpenSSH-4.2p1 with:
> 
> groupadd sshd
> useradd -g sshd sshd
> 
> LIBS="-ldl" ./configure --with-md5-passwords --sysconfdir=/etc/sshd 
> --without-zlib-version-check
> 
> The installation goes fine, and I can start the sshd damon:
> 
> /usr/local/sbin/sshd -Dddd
> 
> When trying to connect from another computer I get asked if I want to 
> add this host to the list of knows hosts. After answering yes the 
> connection is closed, instead of asking me for a password.
> 
> I have tried several different things to solve it.
> 
>    Installing older version of OpenSSL-0.9.7g
>    Installing older version of OpenSSH-4.1p1
>    Enabled MD5 passwords in login.defs
>    Converted to shadow passwords (pwconv and grpconv)
>    Changed the root passwords so it would be MD5 encrypted.
>    Installed OpenSSH and SSHD user, acording to the BLFS description
>   If I install LFS manualy (Not using ALFS) I have no problem installing 
> and using the SSHD daemon.

That's because LFS-6.1 and ALFS includes a broken version of glibc. The 
issue has been raised several times on the LFS and non-LFS lists, but 
was never solved (although the patch was known!) before glibc-2.3.5 
entered the SVN.

-- 
Alexander E. Patrakov



More information about the livecd mailing list