Driverproblem with LFS-6.1 LiveCD rev 1 and 2

Alexander E. Patrakov patrakov at ums.usu.ru
Fri Sep 30 06:13:51 PDT 2005


lfs-user wrote:
> Hi.
> 
> I've just tried to boot a new server with a tekram SCSI-controller and a 
> Plextor SCSI CD-RW, and it fails.  The LiveCD loads the tekram driver, 
> but it fails to find the LiveCD.  I've tested with one of the 6.0 
> versions of the liveCD and that is able to find and complete the boot.
> 
> Does anyone have any hints or fixes for this ?
> 
> More details can be provided if needed.

Known bug, applies to all SCSI controllers. Fixed on the utf8-r0 CD. 
Fixing it by remastering your existing 6.1-2 CD with the proper 
initramfs is also easy.

The thing is that the buggy initramfs has /dev/sr* devices but looks at 
/dev/scd* for your CD. So you should be able to mount the CD, copy all 
files (including hidden ones) to some temporary directory, unpack 
/boot/isolinux/initramfs_data_cpio.gz, and edit the /init file. Replace 
/dev/scd* with /dev/sr*. Pack again with the following command:

find . | cpio -o -H newc | gzip -9 > ../initramfs_data_cpio.gz

Then remaster the CD:

mkisofs -R -l -L -D -o \
     ../lfslivecd-x86-6.1-2.iso -b boot/isolinux/isolinux.bin \
     -c boot/boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table \
     -V "lfslivecd-x86-6.1-2" ./

Then burn the resulting image, it should work. Or just use the utf8-r0 
image if this is easier for you :)

-- 
Alexander E. Patrakov



More information about the livecd mailing list