[lfs-support] lsmod return nothing

包乾 houkensjtu at gmail.com
Sat Mar 22 06:22:35 PDT 2014


thanks for your reply!
I recompile the kernel, actually I copied the kernel source from my host
system(slackware) and everything works fine now!
So the problem narrowed down to my kernel configuration, I would continue
dig into that.
ThX!



On Sat, Mar 22, 2014 at 5:51 PM, Pierre Labastie <pierre.labastie at neuf.fr>wrote:

> Le 22/03/2014 01:23, 包乾 a écrit :
> > hi all!
> > Its been alot of effort and I finally got my LFS 7.4 successfully boot
> on my
> > thinkpad X40.
> >
> > The first problem I encountered was that during the boot process it
> displayed
> > "face eth0 doesn't exist". Well its a typical error msg with driver
> problem.
> > So I went back to host system, figured out which kernel module my NIC
> use( I
> > found it was e1000.ko, a intel NIC driver).
> > Then I go back into LFS, re-configure and re-make the kernel, re-install
> all
> > thing include modules.
> > And weird thing happened. I tried to "modprobe e1000", it return
> nothing, just
> > like successfully loaded. But when I double-check lsmod, there is
> actually
> > NOTHING there-no module was loaded. I wonder if I screwed sth. up during
> the
> > build process or there is other problem...
> >
> > Plz help!
> >
> >
> Did you build e1000 as a module or in the kernel?
> In the latter case, it is normal that modprobe says nothing and that you
> cannot see e1000 as a loaded module.
>
> You can check with:
> grep E1000= /boot/config-... (the config file saved in /boot after building
> the kernel).
>
> If you get:
> CONFIG_E1000=y, it is not built as module, but embedded in the kernel.
> CONFIG_E1000=m, it is built as module.
> CONFIG_E1000=n, it is not built at all.
>
> Now, coming to the issue you have, it may also be that eth0 is renamed to
> something else.
>
> What does 'ip link list' return on the booted system?
>
> Pierre
> --
> http://linuxfromscratch.org/mailman/listinfo/lfs-support
> FAQ: http://www.linuxfromscratch.org/lfs/faq.html
> Unsubscribe: See the above information page
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20140322/8ad07df5/attachment.html>


More information about the lfs-support mailing list