[lfs-support] Blank screen when booting with 3.13.3 kernel. - LFS 7.5

Armin K. krejzi at email.com
Wed Mar 12 09:11:08 PDT 2014


On 03/12/2014 05:09 PM, rhubarbpieguy at gmail.com wrote:
> 
> On 03/12/14 10:19, Merell L. Matlock, Jr. wrote:
>> On 03/12/14 10:54, Armin K. wrote:
>>> On 03/12/2014 03:46 PM, rhubarbpieguy at gmail.com wrote:
>>>> I've built LFS 7.5 with the 3.13.3 kernel but receive a blank screen
>>>> upon booting.  As an experiment, I unselected AGP Support in my kernel
>>>> configuration and can successfully boot.  My thinking was perhaps
>>>> there's a problem with AGP support.
>>>>
>>>> However, as I'm running LFS/BLFS 7.4, I compiled that 3.10.10 kernel in
>>>> my LFS 7.5 build and CAN successfully with with AGP support.  I compiled
>>>> the kernel with the same .config I used when compiling the LFS 7.5
>>>> 3.13.3 kernel.  I also received a blank screen with the 3.13.5 kernel,
>>>> so the problem isn't unique to 3.13.3.
>>>>
>>>> It appears there's a problem with newer kernels.  However, I certainly
>>>> can't ignore the possibility of user error, as that's my "talent."  A
>>>> few questions:
>>>>
>>>> Does it make sense it's a kernel version problem?
>>>>
>>>> If not, what might I have done wrong?
>>>>
>>>> Will there be problems running an older kernel (3.10.10) than the kernel
>>>> with which I built LFS 7.5 (3.13.3)?
>>>>
>>> Have you enabled framebuffer console? CONFIG_FRAMEBUFFER_CONSOLE=y
>>>
>> Similar problem with me; mine was radeon related.  I had to blacklist
>> (/etc/blacklist.conf) the radeon module in 7.4 until I had finished
>> building X and Mesa.  I also spent almost a week before I found out that
>> I also needed firmware for my card as well.  Once I had all the pieces
>> in place, I removed the radeon entry from the blacklist, and it boots
>> fine, with the open-source drivers.  I test-built 7.5 RC-1, leaving
>> radeon totally out of the kernel config, and it booted fine.   I've been
>> off on an arc-tangent for awhile, and I'll get back to 7.5 later.
>>
>> Merell Matlock
> Yes, CONFIG_FRAMEBUFFER_CONSOLE is enabled.
> 

Could you post your kern.log from /var/log after you boot? (you can get
it from chroot after reboot iirc). Compress it before sending or it
might get blocked.

-- 
Note: My last name is not Krejzi.



More information about the lfs-support mailing list