[lfs-support] Installation of Linux API Headers (chapter 6.7.1) problem

Артём Орлов a.orlov at veedo.ru
Tue Sep 24 01:35:40 PDT 2013


> You should be chrooted into your new LFS build before installing the
> headers at step 6.7.1. As such your version of bash should look "similar"
> to this:
> bash -version
> GNU bash, version 4.2.45(2)-release (x86_64-unknown-linux-gnu)
>

My bash version is:
root:/sources# bash -version
GNU bash, version 4.2.45(2)-release (i686-pc-linux-gnu)


> If command substitution is broken in your temp tools bash while in
> chroot, then your host wasn't setup properly. You should have bash as
> your default shell and bison yacc, not some other yacc. The host
> system requirements page helps set the stage for that.
>
>
My linux distribution is Debian 7.1 and 'Berkley LA LR Yacc parser
generator' is installed by default. I should change it to 'YACC-compatible
parser generator' and rebuild bash in tools.

Thank you, gentlemen.

--
With respect,
Artem Orlov
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20130924/05732075/attachment.html>


More information about the lfs-support mailing list