[lfs-support] Getting <su> in Chapter 5 [SOLVED][RESURRECTED]

Dan McGhee beesnees at grm.net
Sun Oct 13 19:50:33 PDT 2013

On 10/13/2013 08:56 PM, Drew Ames wrote:
> The two lines from the install log that I need are
> libtool: install: /usr/bin/install -c su /home/dan/LFS-7.4/shadow/bin/su
> and
> chmod -f 4755 /home/dan/LFS-7.4/shadow/bin/su;
> So after I compile I need either
> make install -c -m 0755 src/su /tools/bin
> or
> install -c -m 0755 src/su /tools/bin
> Which of the two commands will give me the necessary linking I need?
> Does it make a difference? Is the sytax correct. I apologize for being
> such a make and install dummy. It's just one of those things that I
> haven't gotten. BTW, I neither need nor want mode 4755 for the chroot
> environment.
> When I got to chapter 6, as the root user in the chroot environment,
> that copy of su would not switch users to the linux-libc-headers user I
> created for the first package. I got the error:
> bash: /tools/bin/su: No such file or directory
> I then copied su from the host system and got the same results.
> Dan, when you say that su didn't work for you. Did you get an error message?
Drew, good to see you're still around. It has been a long time.

I got no error or anything when I tried. Since I posted, I configured 
and compiled shadow using the book
instructions for its installation in Ch. 6, removed the su I had copied 
earlier, then ran

<install -c -o 0755 src/su /tools/bin>

I got the same results--nothing. I was still root after I ran <su 

I'm stumped. I don't know where to look to troubleshoot. Rob Taylor just 
installed shadow before the linux headers and su worked. He reinstalled 
shadow in the normal course of things. This causes a few hiccups during 
Ch. 6--largely with install directories. I found an "su" file that is 
installed to /etc/pam.d, but since Ch 6 configures shadow not to depend 
on pam--because it's not installed--I doubt that would have any affect 
on the situation.

Before I give up and install the entire shadow pacakge, I'm probably 
going to do a DESTDIR install somewhere in /mnt/lfs and try coping the 
binary to /tools/bin. We'll see what happens.


More information about the lfs-support mailing list