[lfs-support] Unable to login SOLVED

hans kaper spakyelj at xs4all.nl
Sat Oct 5 08:00:06 PDT 2013


Op Fri, 04 Oct 2013 23:13:20 +0200 schreef Bruce Dubbs <bruce.dubbs at gmail.com>:


>>
>> Then: strace -olog.txt login
>>
>
>
> I looked at a trace for my system.  Do you have /etc/group?  These are
> my opens, disregarding library and files not found:
>
> open("/etc/login.defs", O_RDONLY)       = 3
....................
> open("/root/.bash_history", O_RDONLY)   = 3
>
The last part of the list of files were not opened because login did not come that far.

> Check that login.defs, nsswitch.conf, passwd, login.access, and group
> all exist.  Note that shadow is not opened.

Because you use no password?

All the files are there.

I copied passwd, groups and shadow from my succesful build of LFS7_3 to LFS7_4, but no log-in, although a different error-message.

Then, in the end, I re-installed Shadow et voila: a successful login!

Analysing the logs, I saw no differences with the first install, apart from installs by libtool from /usr/bin/install instead of /tools/bin/install, but that shall originate from the fact that in the first build  libtool was build after Shadow.

That leaves the question why the failures occurred in the first place? Any suggestion were I should look in the strace-logfiles to get a clue? LFS is for learning, he?
The login-failure occurred after the password was given. In the successful login login.access was opened, but that was not the case in the failed login, although /etc/login.access existed. There was also no failure of opening that file.


But again, Bruce, I am, very grateful for your extensive help!!



Hans.






More information about the lfs-support mailing list