[lfs-support] LFS for mips64

Graham Crowe graham.crowe.gc at gmail.com
Sun Oct 6 01:03:52 PDT 2013

Hi LFS Team

I recently purchased a Yeeloong Notebook from Lemote, http://www.lemote.com/en/products/Notebook/2010/0310/112.html, and I'm attempting to follow the LFS guide. I'm having problems during chapter 5.

On my first attempt the result from the test in Glibc2.18 (chapter 5.7) was not quite as specified:
it was:

  [Requesting program interpreter: /tools/lib32/ld-linux.so.2]
instead of:

  [Requesting program interpreter: /tools/lib/ld-linux.so.2]

I proceeded but the configure stage of Binutils-2.23.2 - Pass 2 (chapter 5.9) failed due to compiled code not being executable (unfortunately I no longer have the  config.log for this). At this point I made and compiled a simple hello world and tried to run it, that failed and running the file utility on the binary resulted in:

  hello: ELF 32-bit MSB executable, MIPS, N32 MIPS-III version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.32, not stripped

So I made a second attempt to reproduce the fault, but although the test in chapter 7 gave the same result as my first attempt chapter 5.9 appeared to build configure and build successfully. However GCC-4.8.1-Pass 2 (chapter 10) definitely failed, but only after 2.5 hours, complaining about endianess, so something is very wrong. I've attached the config.log for GCC-4.8.1-Pass 2 (chapter 10) and the last few lines of the { make && make install; } step. The gentoo host only has xterm and I haven't figured out how to log the stdout so the quality of the make output is not so good, so some tips for logging would be helpful.

/tools/mips64el-unknown-linux-gnu/bin/ld: Please report this bug.

collect2:error: ld returned 1 exit status
make[2]: *** [libgcc_s.so] Error 1
make[2]: Leaving directory `/mnt/lfs/sources/gcc-build/mips64el-unknown-linux-gnu/libgcc'
make[2]: *** [all-target-libgcc] Error 2
make[2]: Leaving directory `/mnt/lfs/sources/gcc-build'
make[2]: *** [all] Error 2

real    262m58.707s
user   202m21.499s
sys     12m55.740s

I think that the root problem occurred during Glibc2.18 (chapter 5.7) and that I need to prepare something for the mips64 architecture, but I'm not really sure what to do next.

Best Regards

Book Version:

Host distribution & version:

Host System Requirements:
bash, version 4.2.42(1)-release
/bin/sh -> /bin/bash
Binutils: (GNU Binutils) 2.22
bison (GNU Bison) 2.7
/usr/bin/yacc -> /usr/bin/yacc.bison
bzip2,  Version 1.0.6, 6-Sept-2010.
Coreutils:  8.20
diff (GNU diffutils) 3.2
find (GNU findutils) 4.5.10
GNU Awk 4.0.2
/usr/bin/awk -> /usr/bin/gawk
gcc (Gentoo Hardened 4.6.3 p1.3, pie-0.5.3) 4.6.3
g++ (Gentoo Hardened 4.6.3 p1.3, pie-0.5.3) 4.6.3
(GNU libc) 2.15
grep (GNU grep) 2.14
gzip 1.5
Linux version 3.5.4 (root at east) (gcc version 4.6.3 (Gentoo 4.6.3 p1.3, pie-0.5.1) ) #2 PREEMPT Thu Sep 27 16:22:14 Local time zone must be set--see 
m4 (GNU M4) 1.4.16
GNU Make 3.82
GNU patch 2.7.1
Perl version='5.12.4';
sed (GNU sed) 4.2.2
tar (GNU tar) 1.26
Texinfo: makeinfo (GNU texinfo) 4.13
xz (XZ Utils) 5.0.4
g++ compilation OK

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20131006/63d2a618/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: config.log
Type: application/octet-stream
Size: 31172 bytes
Desc: not available
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20131006/63d2a618/attachment.obj>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20131006/63d2a618/attachment-0001.html>

More information about the lfs-support mailing list