[lfs-support] Unable to login

hans kaper spakyelj at xs4all.nl
Fri Oct 4 06:18:48 PDT 2013

Op Thu, 03 Oct 2013 23:04:51 +0200 schreef William Harrington <kb0iic at berzerkula.org>:

> On Oct 3, 2013, at 3:24 PM, hans kaper wrote:
>> I added a line and an error occurred. So login.defs was read.
> Now find the line that is causing the invalid argument
> chroot and run login and see what happens.

The same error!!

> Also, install strace and run login and see what happens.

Installing strace gives a make-error:

gcc -DHAVE_CONFIG_H -I.  -I./linux/i386 -I./linux -I./linux  -Wall -Wwrite-strings -g -O2 -MT process.o -MD -MP -MF .deps/process.Tpo -c -o process.o process.c
In file included from process.c:66:0:
/usr/include/linux/ptrace.h:58:8: error: redefinition of 'struct ptrace_peeksiginfo_args'
  struct ptrace_peeksiginfo_args {
In file included from defs.h:159:0,
                  from process.c:37:
/usr/include/sys/ptrace.h:191:8: note: originally defined here
  struct ptrace_peeksiginfo_args
make[2]: *** [process.o] Error 1
make[2]: Leaving directory `/sources/strace-4.8'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/sources/strace-4.8'
make: *** [all] Error 2

I tried to verify the packet with gpg: error: public key not found.  How to find that key?
I am not that experienced with gpg.

By the way, thanks to Bruce and you for the effort to help me.


More information about the lfs-support mailing list