[lfs-support] Mouse Trouble -- SOLVED

Alan Feuerbacher alanf00 at comcast.net
Tue Nov 26 19:24:11 PST 2013

Again with the great suggestions of several people, I got the mouse to work.

Bottom line: I completely misunderstood the instructions in the BLFS 
book on installing Cups. A note on kernel configuration says:

"There is a conflict between the Cups libusb backend and the usblp 
kernel driver. If you want to use Cups with libusb, do not enable USB 
Printer support in your kernel."

I somehow managed to misinterpret this as not to compile ANY kernel USB 

So I compiled the modules that seem right for my hardware, as shown by 
lspci: modules that mention "EHCI" and "XHCI". I also added whatever 
modules mention "OHCI". Checking the .config file after selecting the 
various USB-related features, I see that there are a bunch of variables 
containing those names, but nothing as simple as "CONFIG_OHCI=y". I had 
already compiled "evdev".

The LFS book states not to compile kernel modules for both OHCI and 
UHCI, so I didn't. But a variable with UHCI in its name has =y anyway. ??

I also carefully went back over the LFS book's instructions on setting 
up the mouse, and rechecked that all the files are set up properly.

/etc/sysconfig/mouse ended up like this:


I tried the program mouse-test in the console window but after 15 
minutes it had not returned, so I killed it.

The GPM daemon works, and X appears to be working fine with the mouse.

The files /dev/input/mice and /dev/input/mouse0 now exist. The first one 
apparently is created BEFORE you fire up linux, while you're compiling 
the kernel (just speculating here), but the latter does not show up 
until after you fire up linux and get a working mouse. I didn't know 
that until now.

Again thanks!


More information about the lfs-support mailing list