[lfs-support] Mouse Trouble

Dan McGhee beesnees at grm.net
Tue Nov 26 09:32:03 PST 2013

On 11/25/2013 10:09 PM, Alan Feuerbacher wrote:
> Now that I've got my linux-3.12 system up and running, and the ethernet
> card running, I'm running into another problem:
> The mouse is not detected.
> The mouse (an older Microsoft Intellimouse USB model) works fine with
> the mouse-based BIOS and with my Fedora installation, so there's
> probably something wrong with my configuration. When I start X, the
> mouse does not light up, which means it's not getting USB power, so it's
> apparently not getting detected.
> In the console window, I've tried running the "mouse-test" program from
> GPM, but it finds no mouse.
> When linux comes up, a message appears: "Starting GPM console mouse
> service...     [OK]".
> After I login as root, and try "ps -ef | grep -i gpm" I see no
> indication that the GPM daemon is running.
> I followed the LFS book to set things up and /etc/sysconfig/mouse has this:
> #######
> MDEVICE="/dev/psaux"
> PROTOCOL="imps2"
> #######
> I've also tried the line "MDEVICE="/dev/input/mice"
> Any ideas as to where I should start looking to solve this?
I got too aggressive on my "delete" button and sent Simon's response 
away. Since you installed 'gpm' did the mouse work before you installed 
Xorg? Again, the driver thing. There are three USB drivers now. UHCI, 
OHCI and EHCI. They *must* be installed in the correct order. The LFS 
book addresses this if you have built them as modules. I personally 
compile all three into the kernel so that I don't have to worry about 
the order. Look at "CONFIG_OHCI" in your kernel configuration file along 
with the corresponding lines for the other two. Use "y" or "m." Once 
you've got the mouse working then it's on to Xorg.

You do not need gpm to have your mouse work in Xorg. If it doesn't right 
now, probably a driver thing. While you're looking into your kernel 
config file, make sure you have configured "evdev" into the kernel or as 
a module. I'm going to make a bold statement here. It may have changed, 
but the last time I built LFS and Xorg, evdev was needed for the mouse 
to work. Maybe even the keyboard, I don't remember.

I like gpm for use in terminals if I don't want to start Xorg.


More information about the lfs-support mailing list