[lfs-support] Mouse Trouble

Pierre Labastie pierre.labastie at neuf.fr
Tue Nov 26 04:50:03 PST 2013

Le 26/11/2013 05:09, Alan Feuerbacher a écrit :
> Now that I've got my linux-3.12 system up and running, and the ethernet
> card running, I'm running into another problem:
> The mouse is not detected.
> The mouse (an older Microsoft Intellimouse USB model) works fine with
> the mouse-based BIOS and with my Fedora installation, so there's
> probably something wrong with my configuration. When I start X, the
> mouse does not light up, which means it's not getting USB power, so it's
> apparently not getting detected.
> In the console window, I've tried running the "mouse-test" program from
> GPM, but it finds no mouse.
> When linux comes up, a message appears: "Starting GPM console mouse
> service...     [OK]".
> After I login as root, and try "ps -ef | grep -i gpm" I see no
> indication that the GPM daemon is running.
> I followed the LFS book to set things up and /etc/sysconfig/mouse has this:
> #######
> MDEVICE="/dev/psaux"
> PROTOCOL="imps2"
> #######
> I've also tried the line "MDEVICE="/dev/input/mice"
> Any ideas as to where I should start looking to solve this?
Hi Alan,

I think it is more likely to be (again) related to some configuration of 
the kernel, if mouse-test does not find it.

With a usb mouse and an adequately configured kernel, you should have 
files named /dev/input/mice and
/dev/input/mouse0. If they do not exist, this is a kernel configuration 
issue. If they exist, you should change MSDEVICE to /dev/input/mice 
(works for me).


More information about the lfs-support mailing list