[lfs-support] Mouse Trouble

Alan Feuerbacher alanf00 at comcast.net
Mon Nov 25 20:09:39 PST 2013

Now that I've got my linux-3.12 system up and running, and the ethernet 
card running, I'm running into another problem:

The mouse is not detected.

The mouse (an older Microsoft Intellimouse USB model) works fine with 
the mouse-based BIOS and with my Fedora installation, so there's 
probably something wrong with my configuration. When I start X, the 
mouse does not light up, which means it's not getting USB power, so it's 
apparently not getting detected.

In the console window, I've tried running the "mouse-test" program from 
GPM, but it finds no mouse.

When linux comes up, a message appears: "Starting GPM console mouse 
service...     [OK]".

After I login as root, and try "ps -ef | grep -i gpm" I see no 
indication that the GPM daemon is running.

I followed the LFS book to set things up and /etc/sysconfig/mouse has this:


I've also tried the line "MDEVICE="/dev/input/mice"

Any ideas as to where I should start looking to solve this?

More information about the lfs-support mailing list