[lfs-support] Ethernet Card Not Found

Dan McGhee beesnees at grm.net
Mon Nov 25 09:06:06 PST 2013


On 11/25/2013 10:50 AM, Bruce Dubbs wrote:
> Dan McGhee wrote:
>> Please excuse the "top post."  I've done it for a reason.
>>
>> Alan, you have gotten a number of great suggestions from some really
>> helpful people.  I think, however, that the waters are very muddy right
>> now.  The main problem is that your system can't find your ethernet
>> card--eth0.  That's the first goal.  After your system sees and
>> acknowledges it's existence, then troubleshoot connecting if any
>> problems persist.
>>
>> On 11/25/2013 08:59 AM, Alan Feuerbacher wrote:
>>> On 11/24/2013 2:33 PM, Pierre Labastie wrote:
>>>>>> lsmod
>>>>>> ######
>>>>>> Module                  Size    Used by
>>>>>> x86_pkg_temp_thermal    4511    0
>>>>>> ######
>> This shows that either the module is not loaded or that it's configured
>> into your kernel.
> No.  It just means that no other module depends on x86_pkg_temp_thermal.
>
>
>>>> I think Bruce was talking about a working distribution (the one you used to
>>>> build LFS for example). Boot it and run lsmod.
>>>> The information you get there could indicate the right driver for the kernel.
>>> Ah! Here's the output from the Fedora host with lsmod :
>>>
>>> #######
>>> Module                  Size  Used by
>>> <snipped irrelevant stuff>
>>>
>>>
>>>
>>> mac80211              564847  1 b43
>>> cfg80211              460310  2 b43,mac80211
> b43 is Broadcom 43xx wireless support
> *80211 are for wireless 802.11 and not needed at this point
>
>>> rfkill                 21694  5 cfg80211,bluetooth,asus_wmi
> RF switch subsystem support -- not needed now
>
> b43 is Broadcom 43xx wireless support
> *80211 are for wireless 802.11 and not needed at this point
>
>>> r8169                  71677  0
>>> mii                    13527  1 r8169
> Looking at the help in the kernel for CONFIG_R8169:
>
> Selects: FW_LOADER [=y] && CRC32 [=y] && MII [=y]
>
> so mii is probably selected automatically.  The question the above line
> gives me is whether there is a firmware blob for this card.
>
>     -- Bruce
Bruce, when I posted, I did not remove the stuff that may not be needed 
just for Alan's card. This is the way his Fedora distro runs. I may not 
have been clear, but only the left column is relevant, and which drivers 
he needed to have configured to get his card working.

Thanks for pointing out the 80211 stuff. Another rust spot for me.

I have the same card and have not yet discovered a "firmware blob." I 
did, however, encounter one for my wireless card. But that's for later 
if he has the same setup that I do.

Dan




More information about the lfs-support mailing list