[lfs-support] Ethernet Card Not Found

Dan McGhee beesnees at grm.net
Mon Nov 25 08:27:46 PST 2013


Please excuse the "top post."  I've done it for a reason.

Alan, you have gotten a number of great suggestions from some really 
helpful people.  I think, however, that the waters are very muddy right 
now.  The main problem is that your system can't find your ethernet 
card--eth0.  That's the first goal.  After your system sees and 
acknowledges it's existence, then troubleshoot connecting if any 
problems persist.

On 11/25/2013 08:59 AM, Alan Feuerbacher wrote:
> On 11/24/2013 2:33 PM, Pierre Labastie wrote:
>>>> lsmod
>>>> ######
>>>> Module                  Size    Used by
>>>> x86_pkg_temp_thermal    4511    0
>>>> ######
This shows that either the module is not loaded or that it's configured 
into your kernel.
>> I think Bruce was talking about a working distribution (the one you used to
>> build LFS for example). Boot it and run lsmod.
>> The information you get there could indicate the right driver for the kernel.
> Ah! Here's the output from the Fedora host with lsmod :
>
> #######
> Module                  Size  Used by
> <snipped irrelevant stuff>
>
>
>
> mac80211              564847  1 b43
> cfg80211              460310  2 b43,mac80211
>
> rfkill                 21694  5 cfg80211,bluetooth,asus_wmi [This may be only for wireless.  I don't know.]
>
> r8169                  71677  0
> mii                    13527  1 r8169
>
This shows you the modules Fedora uses to get your card working.
> BTW, I got the X Windows system running. The expected 3 xterm windows
> pop up, but the mouse does not work. The one window that has focus
> responds to linux commands. I'm certain that there's something wrong
> with how I set up the mouse stuff in the LFS book, but that's for
> another thread.
I recommend you start another thread for this.  Otherwise it might get 
lost in the responses.

To see what might be happening to your ethernet card when LFS boots, run

<dmesg | grep Ethernet>

Here are the results I get:

>  r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
>  Bluetooth: BNEP (Ethernet Emulation) ver 1.3
I left that second line it to show you that you might get a number of 
lines.  But the one you're looking for is the first one.  You and I have 
the same card.

If this doesn't show up, your system somehow does not recognize, can't 
or won't load the driver.  Please refer back to the results of 'lsmod' 
from your Fedora distro.  You need "mac80211", "cfg80211" and "mii" in 
addition to "r8169".  It wouldn't hurt to make sure that rfkill is 
available.  Since we have the same card, I know that yours also supports 
bluetooth and that utilizes "rfkill."

So now you know that you need 
"CONFIG_{MAC80211,CFG80211,MII,RFKILL,R8169}=y or m in your kernel 
.config.  A really easy way to check this is to use <cat -n [config file 
name] | grep SOMETHING>.  The caps are important. For example, here are 
my results from <cat -n /boot/config-3.10.10 | grep R8169>:

> 1843    CONFIG_R8169=m

That reveals what line it's on <cat -n> and how it's set.  You then have 
to merely open the file in an editor and go to that line if you want to 
change it.  Use <grep> to find all the instances of 80211 and the 
others, make any changes you need to and reboot.

FWIW, work on getting eth0 recognized first.  Configure it just like the 
LFS book says and don't worry what Fedora calls it. iptables and routing 
aren't going to help you if your system doesn't see your card.

In my estimation 'dmesg,' 'cat -n,' 'lsmod,' 'lspci,' and 'grep' are 
indispensable troubleshooting tools.

Hope this helps.

Dan





More information about the lfs-support mailing list