[lfs-support] Ethernet Card Not Found

Bruce Dubbs bruce.dubbs at gmail.com
Sat Nov 23 21:19:57 PST 2013

Alan Feuerbacher wrote:
> Howdy,
> Now that my shiny new LFS system is more or less running, I'm trying to
> get all of the bits and pieces runnning.
> The system seems unable to find the ethernet card. The card is actually
> built into the mother board -- a Realtek RTL8111/8168/8411. After
> following the LFS book's instructions (Version SVN-20131105) on
> installing udev, and then the instructions "7.2. General Network
> Configuration", I found that the file
> "/etc/udev/rules.d/70-persistent-net.rules" was not created. A note in
> section 7.2.1 says in this case to "just continue to the next section".
> I'm not sure just which section to continue to, so I continued to
> "7.2.2. Creating Network Interface Configuration Files" and tried to do
> what's instructed there and in section 7.2.3. Unfortunately I have no
> idea how to find out what numbers to plug into the various lines in the
> files ifconfig.eth0 and resolve.conf, and the book gives no suggestions
> how to.
> Can anyone clue me in?

It sounds like you don't have the right ethernet driver built.  We 
recommend building it into the kernel.

> I installed dhcp, following the suggestions in "9.3.

Always keep it simple when debugging.  It's too early for dhcp.

Rebooting the
> System" (along with all the other programs suggested). So when linux
> came up for the first few times, the dhcp client complained that it
> couldn't find "eth0". So I renamed ifconfig.eth0 to something else and
> rebooted. I tried a number of variations on this, and finally looked at
> /sys/class/net. There were two directories: "lo" and "sit0". '

Those are symlinks, not directories.  What that means is what I said 
above.  You don't have the drive built.

BTW, the extension of the ifconfig file is only for your use.  You can 
also name it ifconfig.my-main-ethernet-card if you want.  The scripts 
look for the IFACE setting inside all ifconfig.* scripts.

Also, you can google sit0 fairly easily to see what that is.  Hint: It 
has to do with IPv6.

   -- Bruce

More information about the lfs-support mailing list