[lfs-support] Ethernet Card Not Found

Alan Feuerbacher alanf00 at comcast.net
Sat Nov 23 20:36:30 PST 2013


Now that my shiny new LFS system is more or less running, I'm trying to 
get all of the bits and pieces runnning.

The system seems unable to find the ethernet card. The card is actually 
built into the mother board -- a Realtek RTL8111/8168/8411. After 
following the LFS book's instructions (Version SVN-20131105) on 
installing udev, and then the instructions "7.2. General Network 
Configuration", I found that the file 
"/etc/udev/rules.d/70-persistent-net.rules" was not created. A note in 
section 7.2.1 says in this case to "just continue to the next section". 
I'm not sure just which section to continue to, so I continued to 
"7.2.2. Creating Network Interface Configuration Files" and tried to do 
what's instructed there and in section 7.2.3. Unfortunately I have no 
idea how to find out what numbers to plug into the various lines in the 
files ifconfig.eth0 and resolve.conf, and the book gives no suggestions 
how to.

Can anyone clue me in?

I installed dhcp, following the suggestions in "9.3. Rebooting the 
System" (along with all the other programs suggested). So when linux 
came up for the first few times, the dhcp client complained that it 
couldn't find "eth0". So I renamed ifconfig.eth0 to something else and 
rebooted. I tried a number of variations on this, and finally looked at 
/sys/class/net. There were two directories: "lo" and "sit0". I had 
expected "eth0" rather than "sit0"; I don't know what the latter is. I 
copied ifconfig.eth0 to ifconfig.sit0 and changed the innards 
accordingly, then used ifup to try to bring up the network card 
manually. No luck.

Finally, in "6.62. Udev-208 (Extracted from systemd-208)" there's a 
script executed with "bash udev-lfs-208-1/init-net-rules.sh". I followed 
the commands there manually and found that what it's trying to do simply 
does not work on my system: the files it wants to find in /sys/class/net 
are not there. So somewhere along the line, something has changed so 
that these files don't get created.

Any clues as to how to get this thing up and running?


More information about the lfs-support mailing list