[lfs-support] Error: invalid file name When Booting For the First Time

Dan McGhee beesnees at grm.net
Sat Nov 23 12:21:32 PST 2013

On 11/23/2013 01:32 PM, Alan Feuerbacher wrote:
> On 11/23/2013 4:43 AM, Pierre Labastie wrote:
>> Le 23/11/2013 03:39, Alan Feuerbacher a écrit :
>> At any rate, I recompiled the kernel and reinstalled the grub stuff. I'm
>> still getting an error:
>> error: file '/vmlinuz-3.12-lfs-SVN-20131119' not found.
>> I invoked the grub command line to see what I could see:
>> ls => (hd0) ... (hd1) (hd1,msdos2) (hd1,msdos1) (hd2)
>> So grub apparently sees my disk /dev/sdb as (hd1). Next I tried:
>> ls (hd1) =>
>> Device hd1: No known filesystem detected - Total size 3907029168 sectors
>> I also tried this with (hd0) and (hd2). Same response: no filesystem
>> detected.
>> So for whatever reason, grub is not recognizing the disks. Having tried
>> the same thing with the two other disks, /dev/sda and /dev/sdc, which
>> grub lists above as (hd0) and (hd2), I'm at a loss. All three of these
>> disks are in operation, since when I fire up Fedora19 on /dev/sda, I can
>> write to and read from all of the disks.
>> Any ideas?
By chance, Alan, are you trying to do this with GRUB2 installed on your 
EFI partition after compiling it in EFI mode?  I can't find the 
beginning of this thread, but your results sound suspiciously close, or 
exactly the same as, the results I got during my recent testing. One of 
the conclusions that I have drawn is that GRUB2 in it's current state 
will not boot a kernel compiled and installed via LFS.  Fedora, 
OpenSuse, Ubuntu and one other, seriously hack grub for their own purposes.

The only way I have found to use my UEFI firmware outside of a distro is 
to use the efi stubs of the kernel.  If this is what you're trying to 
do, please respond to the list and I will post a "quick and dirty" 
howto.  I'm in the process of writing a more complete version for the 
list, but it's not ready to post.


More information about the lfs-support mailing list