[lfs-support] Error: invalid file name When Booting For the First Time

Ken Moffat zarniwhoop at ntlworld.com
Sat Nov 23 12:05:17 PST 2013

On Sat, Nov 23, 2013 at 02:32:47PM -0500, Alan Feuerbacher wrote:
> In grub.cfg, why is the "root" in the line "set root=(hd1,1)" different 
> from the "root" in the line "linux /vmlinuz-3.12-lfs-SVN-20131119 
> root=/dev/sdb3 ro"? In other terms I have:
> /dev/sdb1 -> /boot
> /dev/sdb3 -> /
> I'm really fuzzy about this stuff.

 They are totally different things.  Grub purports to be a universal
bootloader, and there is no consistent way of naming disk devices
across different systems, so it uses its own names.

 For the linux kernel bootargs, root= expresses which partition to
load for '/', using the linux kernel's naming system.

> At any rate, I recompiled the kernel and reinstalled the grub stuff. I'm 
> still getting an error:
> error: file '/vmlinuz-3.12-lfs-SVN-20131119' not found.
> I invoked the grub command line to see what I could see:
> ls => (hd0) ... (hd1) (hd1,msdos2) (hd1,msdos1) (hd2)
> So grub apparently sees my disk /dev/sdb as (hd1). Next I tried:
> ls (hd1) =>
> Device hd1: No known filesystem detected - Total size 3907029168 sectors
> I also tried this with (hd0) and (hd2). Same response: no filesystem 
> detected.
> So for whatever reason, grub is not recognizing the disks. Having tried 
> the same thing with the two other disks, /dev/sda and /dev/sdc, which 
> grub lists above as (hd0) and (hd2), I'm at a loss. All three of these 
> disks are in operation, since when I fire up Fedora19 on /dev/sda, I can 
> write to and read from all of the disks.
> Any ideas?
> Alan

 How about ls (hd1,1) ?  hd0 and hd1 are the whole disk, what you
need to look at is a partition.

 I've also got a much-less-important comment on your kernel names as
a reply to your earlier post: You had four variants of 3.12 lfs
kernels.  All of them had the same size in bytes, one was from nearly
two days before the rest, of the others two had the same time and the
other was a second later.  To me, that looks unusual :

 Mostly, a fresh build with different options will produce a kernel
with a slightly different size.  It's not impossible that minor
changes might produce same-size binaries, but obviously with
different md5sums.  But when I see three kernels with essentially
the same time I start to worry - I don't think even the fastest
machines can produce an updated kernel so quickly.

das eine Mal als Tragödie, dieses Mal als Farce

More information about the lfs-support mailing list