[lfs-support] Error: invalid file name When Booting For the First Time

Alan Feuerbacher alanf00 at comcast.net
Sat Nov 23 11:32:47 PST 2013

On 11/23/2013 4:43 AM, Pierre Labastie wrote:
> Le 23/11/2013 03:39, Alan Feuerbacher a écrit :
> I do not see "vmlinuz-3.12-lfs-SVN-20131105" (as mentioned in
> /boot/grub/grub.cfg) in the listing of the /boot directory...
> I think the line in grub.cfg could be:
> linux /vmlinuz-3.12-lfs-SVN-20131119 root=/dev/sdb3 ro
> with 3 changes:
> vmlinuz  -> /vmlinuz
> 20131105 -> 20131119
> /dev/sdb1 -> /dev/sdb3

Duh. That's what I get for trying to do this stuff late at night when 
I'm tired.

> The last one is because your root filesystem is on /dev/sdb3. root=... tells
> the kernel where / is.

In grub.cfg, why is the "root" in the line "set root=(hd1,1)" different 
from the "root" in the line "linux /vmlinuz-3.12-lfs-SVN-20131119 
root=/dev/sdb3 ro"? In other terms I have:

/dev/sdb1 -> /boot
/dev/sdb3 -> /

I'm really fuzzy about this stuff.

At any rate, I recompiled the kernel and reinstalled the grub stuff. I'm 
still getting an error:

error: file '/vmlinuz-3.12-lfs-SVN-20131119' not found.

I invoked the grub command line to see what I could see:

ls => (hd0) ... (hd1) (hd1,msdos2) (hd1,msdos1) (hd2)

So grub apparently sees my disk /dev/sdb as (hd1). Next I tried:

ls (hd1) =>
Device hd1: No known filesystem detected - Total size 3907029168 sectors

I also tried this with (hd0) and (hd2). Same response: no filesystem 

So for whatever reason, grub is not recognizing the disks. Having tried 
the same thing with the two other disks, /dev/sda and /dev/sdc, which 
grub lists above as (hd0) and (hd2), I'm at a loss. All three of these 
disks are in operation, since when I fire up Fedora19 on /dev/sda, I can 
write to and read from all of the disks.

Any ideas?


More information about the lfs-support mailing list