[lfs-support] LFS 7.3 Screen Flickering problem

Ken Moffat zarniwhoop at ntlworld.com
Fri Nov 22 12:46:13 PST 2013

On Fri, Nov 22, 2013 at 09:17:16AM -0600, Douglas R. Reno wrote:
> Hello,
> After completing a successful build of LFS, I restart to get into the
> system for the first time and my screen turns black and then comes back on
> for about 1 second.
> I have a NVidia Vanta LT card in my PC. I am using the Nouveau drivers for
> the framebuffer, as I plan to install X. I have Nouveau configured as well
> in the kernel.
> I can tell that the system booted successfully,

 Excuse me for being a pedant, but *how* do you tell that the
system booted successfully ?  If you have been back to chroot and
managed to read logs, then yes, it booted and there might be a
message somewhere in the log (search for 'nouveau' or

 If you haven't got logs, then here is my impression of what is
happening:  Grub passes control to your new kernel - screen goes
black, initial messages appear using probably an 80x25 vga console,
then it tries to switch to the framebuffer console and goes black.

 Are the framebuffer and KMS options built in to the kernel, or as
modules ?  If you leave it for 60 seconds, does it give you any
error message and then procede ?  If you leave it for 180+ seconds
(I suggest trying something a little longer, e.g. 5 minutes, just to
be sure) does it reboot ?

 The first would probably be related to either failing to load a
module, or failing to load firmware and the message ought to provide
an indication of what is needed.  The reboot after 3+ minutes would
indicate it oopsed and tried to kill init.

> but I have already tried
> various options in kernel configuration (such as Generic VESA). I would
> also like to keep my bootlogo, but I am willing to remove it if necessary.

 If you mean the penguin(s), it/they come with the framebuffer and
KMS requires a framebuffer.

 For a recent kernel using KMS, you should enable
CONFIG_FRAMEBUFFER_CONSOLE and the appropriate DRM entry, but NONE of
the Frame buffer hardware_drivers [ CONFIG_FB_CIRRUS...SIMPLE ]
should not be set.
> The system appears to have issues detecting the card because of the
> resolution (it stays at about 640x480). I have booted several LiveCDs
> (Ubuntu and System Rescue CD) successfully without this problem.
> Host: System Rescue CD (added bison to image)
> NOTE: this system is i686
> Compaq Presario 5230us if that helps.
> Thank you,
> Douglas Reno

das eine Mal als Tragödie, dieses Mal als Farce

More information about the lfs-support mailing list