[lfs-support] Step 5.4.1 Installation of Cross Binutils errors

Vasco Almeida vmsda at netcabo.pt
Thu Nov 14 02:37:57 PST 2013


On his last message, Ken Moffat wrote:
This looks as if makeinfo in now *required*. Try installing texinfo on 
the host.

However, on a previous message, Walter P. Little had already cautioned me:

You may have already done this, but just in case something got missed, for
what it's worth, here's what I had to do to prep a stock Ubuntu 12.04
install for building LFS-7.4:
-  change /bin/sh symlink to point to /bin/bash instead of /bin/dash
-  install the following packages:  build-essential, bison, gawk, texinfo

And I am not ignoring Pierre Labastie's command:
Texinfo 4.9 is in the "host system requirements" section (preface vii)...Vasco, please, have a look at that page.


I did strive to be more careful (and responsible) this time. So I ran the version check script from VII, and am attaching the output for your perusal. From it, I conclude:
1. On my Ubuntu I should install at least/bison, gawk, g++, m4/  and/makeinfo/  (via apt-get install/packa//ge-name/, assuming these are indeed the names).
2. Possibly, I should also install/build-essential/.
3. Change the symlink as suggested by Walter.

I did run the version-check at the beginning but obviously did not pay enough attention to the output on the console. Sorry for the oversight and the hassle caused. In future I shall redirect outputs to files and check them carefully.

Thank you again, gentlemen. Best regards.

Vasco

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20131114/44dfd571/attachment.html>
-------------- next part --------------
bash, version 4.2.25(1)-release
/bin/sh -> /bin/dash
Binutils: (GNU Binutils for Ubuntu) 2.22
version-check.sh: line 8: bison: command not found
yacc not found
bzip2,  Version 1.0.6, 6-Sept-2010.
Coreutils:  8.13
diff (GNU diffutils) 3.2
find (GNU findutils) 4.4.2
version-check.sh: line 17: gawk: command not found
/usr/bin/awk -> /usr/bin/mawk
gcc (Ubuntu/Linaro 4.6.3-1ubuntu5) 4.6.3
version-check.sh: line 23: g++: command not found
(Ubuntu EGLIBC 2.15-0ubuntu10.5) 2.15
grep (GNU grep) 2.10
gzip 1.4
Linux version 3.5.0-43-generic (buildd at roseapple) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #66~precise1-Ubuntu SMP Thu Oct 24 14:52:23 UTC 2013
version-check.sh: line 28: m4: command not found
GNU Make 3.81
patch 2.6.1
Perl version='5.14.2';
GNU sed version 4.2.1
tar (GNU tar) 1.26
version-check.sh: line 34: makeinfo: command not found
Texinfo: 
xz (XZ Utils) 5.1.0alpha
version-check.sh: line 37: g++: command not found
g++ compilation failed


More information about the lfs-support mailing list