[lfs-support] SOLVED: lfs 7.4 section 5.9.1. Installation of Binutils error: Cannot run C compiled programs

Ron Hartikka hartikka at gmail.com
Tue Nov 12 19:27:20 PST 2013

This looks like virgo's problem at...


I was pasting from the 7.4 online book into a terminal window.

I got to this point (5.9.1):

*CC=$LFS_TGT-gcc                \
AR=$LFS_TGT-ar                 \
RANLIB=$LFS_TGT-ranlib         \
../binutils-2.23.2/configure   \
    --prefix=/tools            \
    --disable-nls              \
    --with-lib-path=/tools/lib \

I selected all of that at once, middle-mouse-pasted it into my
terminal, and hit return.
I had entered many multilined commands this way and all seemed to work.
But this time, like Virgo, I got this error:
*Cannot run C compiled programs *
I repeated all of chapter 5 up to there with the same result.

I studied the situation and found that echo $CC produced a blank line.
So CC was not set. Nor, as I recall, were AR and RANLIB.

So I pasted the lines one at a time with out the backslashes.
And all is well. I don't know why.

Ron Hartikka
hartikka at gmail.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20131112/098d0982/attachment.html>

More information about the lfs-support mailing list