[lfs-support] ifup--a really uninformed question

Dan McGhee beesnees at grm.net
Fri Nov 1 15:31:24 PDT 2013


It has been so very, very long since I have worked with the 
bootscripts.  I have just forgotten.  Please pardon this really basic 
question.

If I want to bring up my wireless card, will <ifup wifi0> work 
backwards, using the service scripts in /etc/sysconfig, or do I need to 
run 'ifup' twice? <ifup wlan0 && ifup wifi0>

I have all the correct files installed for wpa_supplicant and dhcpcd and 
wlan0.  I reviewed 'ifup' and the only variable it works with is ${1}, 
and in this case it was wifi0.  I got the messages that dhcpcd and 
wpa_supplicant had started on wlan0, but when I tried to ping my router 
I got the message "NETWORK NOT AVAILABLE."

I probably needed to say that I'm doing this from chroot environment.  I 
disconnected from my router and turned off the card in Ubuntu.  Then I 
ran the 'ifup' command in chroot.  In 'dmesg' I saw that the kernel was 
trying to associate, but there was no message that wlan0 was ready.  I'm 
thinking that I didn't trigger the udevd event that I thought I would.

I thought that in one of my previous LFS builds, I had used my network 
in the chroot environment.  I remember using wget and lynx from a 
terminal, but I just can't remember if it was in chroot or after I 
booted into the LFS system.

I know I'm missing something pretty simple, but I just can't dredge it up.

Thanks.
Dan




More information about the lfs-support mailing list