[lfs-support] ifup--a really uninformed question

Bruce Dubbs bruce.dubbs at gmail.com
Fri Nov 1 17:52:07 PDT 2013

Dan McGhee wrote:
> It has been so very, very long since I have worked with the
> bootscripts.  I have just forgotten.  Please pardon this really basic
> question.
> If I want to bring up my wireless card, will <ifup wifi0> work
> backwards, using the service scripts in /etc/sysconfig, or do I need to
> run 'ifup' twice? <ifup wlan0 && ifup wifi0>
> I have all the correct files installed for wpa_supplicant and dhcpcd and
> wlan0.  I reviewed 'ifup' and the only variable it works with is ${1},
> and in this case it was wifi0.  I got the messages that dhcpcd and
> wpa_supplicant had started on wlan0, but when I tried to ping my router
> I got the message "NETWORK NOT AVAILABLE."
> I probably needed to say that I'm doing this from chroot environment.  I
> disconnected from my router and turned off the card in Ubuntu.  Then I
> ran the 'ifup' command in chroot.  In 'dmesg' I saw that the kernel was
> trying to associate, but there was no message that wlan0 was ready.  I'm
> thinking that I didn't trigger the udevd event that I thought I would.
> I thought that in one of my previous LFS builds, I had used my network
> in the chroot environment.  I remember using wget and lynx from a
> terminal, but I just can't remember if it was in chroot or after I
> booted into the LFS system.
> I know I'm missing something pretty simple, but I just can't dredge it up.

No, you are not missing something simple.  I don't have a wireless 
device so I've never tried to set that up.  However, I do know enough 
that the wireless card must be able to connect to the access point and 
then dhcp needs to get the address.

There is a capability in the scripts to use multiple services.  For 
instance, a bridged network does:

SERVICE="bridge ipv4-static"  # Space separated
CHECK_LINK=no                 # Don't check before bridge is created
STP=no                        # Spanning tree protocol, default no
INTERFACE_COMPONENTS="eth0"   # Add to IFACE, space separated devices

For wireless, there would need to be something like:

SERVICE="wireless dhcpcd"

The device may need to be specified separately with something like:


In any case, we don't have a wireless service right now, although we do 
have a dhcpcd service.

   -- Bruce

More information about the lfs-support mailing list