[lfs-support] [solved] RE: lfs-support Digest, Vol 2823, Issue 1

Rubin Saifi rubinsaifi at live.com
Thu Mar 21 21:47:43 PDT 2013


Dear friend , you need to compile your kernel again with PCNET32 ETHERNET DRIVER [*] option , do remember [*] option not [m] and your eth0 will be working

> From: lfs-support-request at linuxfromscratch.org
> Subject: lfs-support Digest, Vol 2823, Issue 1
> To: lfs-support at linuxfromscratch.org
> Date: Thu, 21 Mar 2013 00:00:01 -0600
> 
> Send lfs-support mailing list submissions to
> 	lfs-support at linuxfromscratch.org
> 
> To subscribe or unsubscribe via the World Wide Web, visit
> 	http://linuxfromscratch.org/mailman/listinfo/lfs-support
> or, via email, send a message with subject or body 'help' to
> 	lfs-support-request at linuxfromscratch.org
> 
> You can reach the person managing the list at
> 	lfs-support-owner at linuxfromscratch.org
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of lfs-support digest..."
> 
> 
> Today's Topics:
> 
>    1. Re:  eth0 issue NO SUCH DEVICE (xinglp)
>    2. Re:  eth0 issue NO SUCH DEVICE (Pierre Labastie)
>    3. Re:  eth0 issue NO SUCH DEVICE (Bruce Dubbs)
>    4. Re:  Configuring the Linux Console for Japanese Environment
>       (LFS 7.0) (Ken Moffat)
> 
> 
> ----------------------------------------------------------------------
> 
> Message: 1
> Date: Wed, 20 Mar 2013 14:41:59 +0800
> From: xinglp <xinglp at gmail.com>
> Subject: Re: [lfs-support] eth0 issue NO SUCH DEVICE
> To: LFS Support List <lfs-support at linuxfromscratch.org>
> Message-ID:
> 	<CAHQM783anjfjdvuiaAPFtZs_VYO1Pe4jzUn=dakVKYYt7-zL1Q at mail.gmail.com>
> Content-Type: text/plain; charset=UTF-8
> 
> 2013/3/20 Rubin Saifi <rubinsaifi at live.com>:
> > /run/var/bootlog : no such file or directory
> > /etc/sysconfig/ifconfig.eth0 -> well configured
> > /etc/sysconfig/network -> well configured
> > ifup eth0 -> no device eth0
> >
> >
> > i am done with the LFS book and the LFSBox is up and running but before the
> > root login it shows that no interface eth0 , no such device etc,...... what
> > should be done to get eth0 up and working
> What's in /sys/class/net ?
> >
> > --
> > http://linuxfromscratch.org/mailman/listinfo/lfs-support
> > FAQ: http://www.linuxfromscratch.org/lfs/faq.html
> > Unsubscribe: See the above information page
> >
> 
> 
> ------------------------------
> 
> Message: 2
> Date: Wed, 20 Mar 2013 11:08:27 +0100
> From: Pierre Labastie <pierre.labastie at neuf.fr>
> Subject: Re: [lfs-support] eth0 issue NO SUCH DEVICE
> To: LFS Support List <lfs-support at linuxfromscratch.org>
> Message-ID: <51498A9B.7000004 at neuf.fr>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
> 
> Le 20/03/2013 07:41, xinglp a ?crit :
> > 2013/3/20 Rubin Saifi<rubinsaifi at live.com>:
> >> /run/var/bootlog : no such file or directory
> >> /etc/sysconfig/ifconfig.eth0 ->  well configured
> >> /etc/sysconfig/network ->  well configured
> >> ifup eth0 ->  no device eth0
> >>
> >>
> >> i am done with the LFS book and the LFSBox is up and running but before the
> >> root login it shows that no interface eth0 , no such device etc,...... what
> >> should be done to get eth0 up and working
> > What's in /sys/class/net ?
> Also, you can try 'ip link list'. It should give you the name of the 
> network interface (together with some other information). Modern udev 
> tends to rename network interface to names like enpXsY where X and Y are 
> numbers.
> It is also possible that you did not enable your specific network card 
> in the kernel configuration.
> If you find some enpXsY either by doing ip link list or by listing 
> /sys/class/net, try replacing the line 'IFACE=eth0' by IFACE='enpXsY' in 
> /etc/sysconfig/ifconfig.eth0 (renaming the file is not mandatory, 
> although it is cleaner IMHO).
> 
> Regards
> Pierre
> 
> 
> 
> ------------------------------
> 
> Message: 3
> Date: Wed, 20 Mar 2013 11:37:54 -0500
> From: Bruce Dubbs <bruce.dubbs at gmail.com>
> Subject: Re: [lfs-support] eth0 issue NO SUCH DEVICE
> To: LFS Support List <lfs-support at linuxfromscratch.org>
> Message-ID: <5149E5E2.8090700 at gmail.com>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
> 
> Pierre Labastie wrote:
> > Le 20/03/2013 07:41, xinglp a ?crit :
> >> 2013/3/20 Rubin Saifi<rubinsaifi at live.com>:
> >>> /run/var/bootlog : no such file or directory
> 
> That's specifically deleted at the end of the boot process.  Try 
> /var/log/boot.log which is a copy after the disk becomes writable.
> 
> >>> /etc/sysconfig/ifconfig.eth0 ->  well configured
> >>> /etc/sysconfig/network ->  well configured
> >>> ifup eth0 ->  no device eth0
> 
> >>> i am done with the LFS book and the LFSBox is up and running but before the
> >>> root login it shows that no interface eth0 , no such device etc,...... what
> >>> should be done to get eth0 up and working
> 
> >> What's in /sys/class/net ?
> 
> > Also, you can try 'ip link list'. It should give you the name of the
> > network interface (together with some other information). Modern udev
> > tends to rename network interface to names like enpXsY where X and Y are
> > numbers.
> > It is also possible that you did not enable your specific network card
> > in the kernel configuration.
> > If you find some enpXsY either by doing ip link list or by listing
> > /sys/class/net, try replacing the line 'IFACE=eth0' by IFACE='enpXsY' in
> > /etc/sysconfig/ifconfig.eth0 (renaming the file is not mandatory,
> > although it is cleaner IMHO).
> 
> Another issue is the hw environment.  If working in a virtual 
> environment, eth0 may not exist and the interface will be something like 
> enp1s3.  Normally this is renamed by udev, but it is purposely skipped 
> in a virtual environment.
> 
>    -- Bruce
> 
> 
> 
> 
> ------------------------------
> 
> Message: 4
> Date: Wed, 20 Mar 2013 21:43:04 +0000
> From: Ken Moffat <zarniwhoop at ntlworld.com>
> Subject: Re: [lfs-support] Configuring the Linux Console for Japanese
> 	Environment (LFS 7.0)
> To: LFS Support List <lfs-support at linuxfromscratch.org>
> Message-ID: <20130320214304.GA21959 at milliways>
> Content-Type: text/plain; charset=utf-8
> 
> [ this response contains a few UTF-8 japanese glyphs ]
> 
> On Wed, Mar 20, 2013 at 01:06:51AM +0700, Andi Blacktigerbro wrote:
> > I'm trying to build LFS with fully supported Japanese Environment and can
> > be switched into English, but only use US-EN keyboard input and for
> > Japanese input I prefer to use Anthy/SCIM
> > Now I'm on chapter 7.10. Configuring the Linux Console - LFS 7.0 but I have
> > problem chossing the KEYMAP
> > Should I use this
> > -----------
> > cat > /etc/sysconfig/console << "EOF"
> > # Begin /etc/sysconfig/console
> > 
> > KEYMAP="jp106"
> > 
> > # End /etc/sysconfig/console
> > EOF
> > -----------
> > or maybe just US-EN KEYMAP or something else? but the console at later time
> > should able to display hiragana, katakana, and kanji characters.
> > 
>  I don't think the console can display kanji.  If you use the bright
> colours, you can have a total of 256 glyphs.  If you do without the
> bright ones you can have up to 512 glyphs, at least in a framebuffer.
> There are also size issues for the character cell (the largest
> standard fonts I'm aware of are 12x22, which maybe _requires_ a
> framebuffer, but most are something like 8x16 or smaller - perhaps
> there are enough available glyphs for ASCII, hiragana, katakana but
> you might struggle to find a suitable console font).
> 
>  I can see occasional references to console projects, but the
> easiest way to display any of those writing systems is to use
> terminals in Xorg.  The legacy xorg fonts, or modern TrueType/OTF
> fonts, will happily display all of those writing systems.  I'm not
> sure if xterm itself can do that, but certainly rxvt-unicode can.
> 
>  This is what translate.google thinks is the katakana for Andi, I've
> keyed the first 4 codes using ISO-14755 format in rxvt-unicode and
> pasted the fifth because I can't recognize it from the hiragana or
> katakana glyphs listed in gucharmap: ????? (codes U+30A2,
> U+30F3, U+30C7 U+30A3) : for me that renders identically in
> rxvt-unicode and in firefox.  I'm guessing the last glyph is U+30FC
> "katakana+hiragana prolonged sound mark" ? which gucharmap shows in
> the 'common' area.
> 
>  Do you actually need a console for those writing systems, or would
> using them in a browser / graphical mail client / office programs be
> adequate ?  I use mutt for my email, but I subscribe to the lkml
> list and when I read mail in rxvt-unicode I am able to render the
> CJK [ Kanji, Chinese, Korean ] glyphs which appear in people's names
> and standard introductory remarks.
> 
>  For the console itself, I guess jp106 is your only sensible choice
> (or if your keyboard has subtle differences, for example because you
> use a laptop where some keys have been rearranged, copy jp106 and use
> it to create a corrected version for your machine).
> 
> ?en
> -- 
> das eine Mal als Trag?die, das andere Mal als Farce
> 
> 
> ------------------------------
> 
> -- 
> http://linuxfromscratch.org/mailman/listinfo/lfs-support
> FAQ: http://www.linuxfromscratch.org/lfs/faq.html
> Unsubscribe: See the above information page
> 
> 
> End of lfs-support Digest, Vol 2823, Issue 1
> ********************************************
 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20130322/e02c6281/attachment.html>


More information about the lfs-support mailing list