[lfs-support] Can't install grub - LFS 7.0

Bruce Dubbs bruce.dubbs at gmail.com
Thu Mar 21 13:39:13 PDT 2013


Andi Blacktigerbro wrote:
> I have problem installing grub
>
> already creating the /etc/fstab File
> ------------------
> cat > /etc/fstab << "EOF"
> # Begin /etc/fstab
>
> # file system  mount-point  type   options         dump  fsck
> #                                                        order
>
> /dev/sda7      /            ext3   defaults        1     1
> /dev/sda6      swap         swap   pri=1           0     0
> proc           /proc        proc   defaults        0     0
> sysfs          /sys         sysfs  defaults        0     0
> devpts         /dev/pts     devpts gid=4,mode=620  0     0
> tmpfs          /run         tmpfs  defaults        0     0
> # End /etc/fstab
> EOF
> ------------------
> sda7 is my lfs partition
> sda6 is my host swap (debian) because I did not create swap for lfs
> ------------
> already done
> ------------
>   cd /tmp && grub-mkrescue --output=grub-img.iso && xorriso -as cdrecord -v
> dev=/dev/cdrw blank=as_needed grub-img.iso
>
> -------------
> and already remount
> -----
> mount -v --bind /dev $LFS/dev
> mount -vt devpts devpts $LFS/dev/pts
> mount -vt tmpfs shm $LFS/dev/shm
> mount -vt proc proc $LFS/proc
> mount -vt sysfs sysfs $LFS/sys
> -----
> the command and result
> ----
> root:/# grub-install /dev/sda
> /usr/sbin/grub-probe: error: cannot stat `/dev/sda7'.
> ----
> Is something I left?

Do you have /dev/sda7?  If you created the partition, you may need to do 
partprobe for the kernel to know it's there.

But why are you using LFS 7.0?  It was released Sep 2011.  Current is 
LFS 7.3.  IIRC grub was 1.97 at the time.  It is 2.0 now.

   -- Bruce






More information about the lfs-support mailing list