[lfs-support] Can't install grub - LFS 7.0

Andi Blacktigerbro bl4cktig3rbro at gmail.com
Thu Mar 21 13:26:59 PDT 2013


I have problem installing grub

already creating the /etc/fstab File
------------------
cat > /etc/fstab << "EOF"
# Begin /etc/fstab

# file system  mount-point  type   options         dump  fsck
#                                                        order

/dev/sda7      /            ext3   defaults        1     1
/dev/sda6      swap         swap   pri=1           0     0
proc           /proc        proc   defaults        0     0
sysfs          /sys         sysfs  defaults        0     0
devpts         /dev/pts     devpts gid=4,mode=620  0     0
tmpfs          /run         tmpfs  defaults        0     0
# End /etc/fstab
EOF
------------------
sda7 is my lfs partition
sda6 is my host swap (debian) because I did not create swap for lfs
------------
already done
------------
 cd /tmp && grub-mkrescue --output=grub-img.iso && xorriso -as cdrecord -v
dev=/dev/cdrw blank=as_needed grub-img.iso

-------------
and already remount
-----
mount -v --bind /dev $LFS/dev
mount -vt devpts devpts $LFS/dev/pts
mount -vt tmpfs shm $LFS/dev/shm
mount -vt proc proc $LFS/proc
mount -vt sysfs sysfs $LFS/sys
-----
the command and result
----
root:/# grub-install /dev/sda
/usr/sbin/grub-probe: error: cannot stat `/dev/sda7'.
----
Is something I left?
-- 
[Andi is your brother]
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20130322/2ae26283/attachment.html>


More information about the lfs-support mailing list