[lfs-support] VLC-2.0.5 shenanigans

Arthur Radley misterarthurradley at gmail.com
Thu Mar 14 06:34:00 PDT 2013


On 03/14/2013 01:11 AM, Armin K. wrote:
> On 03/14/2013 03:33 AM, Arthur Radley wrote:
>> Hello everybody,
>>
>> Short version...
>>
>> If VLC-2.0.5 does not build and you installed libdvbpsi, then try VLC
>> again after uninstalling libdvbpsi.
>>
>>
>>
>> Long version...
>>
>> I have been installing VLC in my last 5 or 6 BLFS systems. I like it.
>> It's always a big project, but I've always gotten through it. Not this time.
>>
>> First, I see this after the patch and configure command...
>>
>>
>>
>> generating modules/**/Makefile.am
>> .....................................................................
>> + echo
>> + cp -f INSTALL INSTALL.git
>> + autoreconf --install --force --verbose -I m4
>> autoreconf: Entering directory `.'
>> autoreconf: running: autopoint --force
>> Copying file ABOUT-NLS
>> Copying file m4/fcntl-o.m4
>> Copying file m4/threadlib.m4
>> Copying file po/Makevars.template
>> autoreconf: running: aclocal -I m4 --force -I m4
>> configure.ac:28 <http://configure.ac:28>: error: 'AM_CONFIG_HEADER':
>> this macro is obsolete.
>>       You should use the 'AC_CONFIG_HEADERS' macro instead.
>> /usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded
>> from...
>> configure.ac:28 <http://configure.ac:28>: the top level
>> autom4te: /usr/bin/m4 failed with exit status: 1
>> aclocal: error: echo failed with exit status: 1
>> autoreconf: aclocal failed with exit status: 1
>>
>>
>>
>> My understanding is that stuff is related to the sudden removal of a
>> long-deprecated macro from automake and now we sometimes see these
>> warnings. Okay, fine. I wasn't able find out what to do about it. VLC
>> would still continue on with the make command but then fail midway with
>> this...
>>
>>
>>
>> dtv/en50221.c: In function 'en50221_SetCAPMT':
>> dtv/en50221.c:2234:17: error: implicit declaration of function
>> 'dvbpsi_DeletePMT' [-Werror=implicit-function-declaration]
>> dtv/en50221.c: At top level:
>> dtv/en50221.c:2288:12: warning: 'en50221_OpenMMI' defined but not used
>> [-Wunused-function]
>> dtv/en50221.c:2328:12: warning: 'en50221_CloseMMI' defined but not used
>> [-Wunused-function]
>> dtv/en50221.c:2356:15: warning: 'en50221_GetMMIObject' defined but not
>> used [-Wunused-function]
>> dtv/en50221.c:2381:13: warning: 'en50221_SendMMIObject' defined but not
>> used [-Wunused-function]
>> cc1: some warnings being treated as errors
>> make[5]: *** [libdtv_plugin_la-en50221.lo] Error 1
>> make[5]: Leaving directory
>> `/mnt/files5/blfs/svn/sources-hubble/vlc-2.0.5/modules/access'
>> make[4]: *** [all-recursive] Error 1
>> make[4]: Leaving directory
>> `/mnt/files5/blfs/svn/sources-hubble/vlc-2.0.5/modules/access'
>> make[3]: *** [all] Error 2
>> make[3]: Leaving directory
>> `/mnt/files5/blfs/svn/sources-hubble/vlc-2.0.5/modules/access'
>> make[2]: *** [all-recursive] Error 1
>> make[2]: Leaving directory
>> `/mnt/files5/blfs/svn/sources-hubble/vlc-2.0.5/modules'
>> make[1]: *** [all-recursive] Error 1
>> make[1]: Leaving directory `/mnt/files5/blfs/svn/sources-hubble/vlc-2.0.5'
>> make: *** [all] Error 2
>>
>>
>> There are a bunch anecdotal things on the Internet about this. Some of
>> them are not even recent. Some say it's caused by kernel 3.7 and up.
>> Some say it's the new version libdvbpsi (v1.0.0). And so on. Okay, fine.
>> I spent a day trying all kinds of things related to those ideas. VLC
>> with the old libdvbpsi-0.2.2. No. VLC with kernel 3.5.2 from my old LFS
>> 7.2 stash. No. I tried the previous VLC-2.0.3 which built and installed
>> fine six months ago. No. Finally, I tried VLC-2.0.5 with no libdvbpsi at
>> all. YES! I still see the automake stuff with configure, of course. But
>> VLC goes on to build and install and work. I will find out later what
>> difference not having the optional package libdvbpsi makes.
>>
>> I know this post was long. And I don't know what value this has for the
>> book. But I thought I should say something about it, and I didn't how
>> else to say it all.
>>
>> A.Radley
>>
>>
>
> http://www.videolan.org/developers/libdvbpsi.html
>
> Scroll down and you'll find:
>
> The latest libdvbpsi (LGPL v2.1) release version 1.0.0. Note: the API
> has changed since version 0.2.2 you need to update your applications.
>
> In short, you can't use VLC with libdvbpsi 1.0.0.
>
Saw that. It's what made me start playing around with libdvbpsi. I tried 
reverting back to v0.2.2 which caused no problems six months ago with 
VLC-2.0.3. But now, with VLC-2.0.5, neither version helped my problem. 
Only ditching libdvbpsi completely did. I also could not install 
VLC-2.0.3 in this new BLFS system, but I forgot to note which version of 
libdvbpsi was installed at the time (probably 1.0.0).

A. Radley



More information about the lfs-support mailing list