[lfs-support] LFS-7.3

Frans de Boer frans at fransdb.nl
Tue Mar 5 15:53:52 PST 2013


On 03/06/2013 12:38 AM, Nicholas McCurdy-Luksch wrote:
> I had the same problem with 7.2...  I never found a satisfactory cause, but my solution was to re-run the script (after a few minutes of looking around for the source of the problem and doing nothing in the process)...  it completed properly that time.
>
> My scripts were identical copy pasta from the online book...  unsure why it worked the second time.
>
> I hope this is of use, and perhaps someone else can explain how i got so lucky with it...  :)
>
>
> Note: Please forgive the top-post, my phone doesn't allow me to position the quote as i want to...
>
>
> Nicholas McCurdy-Luksch
> mindwarpstudios at aim.com
>
> Rick Berube <rick.berube at gmail.com> wrote:
>
>> At section 6.25 E2fspros installation, the make script emitted:
>>
>> could not open ../lib/et/com_err.texinfo: No such file or directory
>> install: cannot stat 'doc/com_err.info': No such file or directory
>> install-info: No such file or directory for /usr/share/info/com_err.info
>>
>> These were the last three steps in the script.
>>
>> I've compared my script to the published one on the web-site and in the
>> book.  The are all the same.  The log compares the same up to the final
>> three steps.
>>
>> Any clues?  Help is truly well-appreciated.
>>
>> Thanks
>> --
>> Rick Berube
>> ------
>> This fevered ranting was generated randomly. Any resemblance to coherent
>> thought is completely coincidental.
>> --
>> http://linuxfromscratch.org/mailman/listinfo/lfs-support
>> FAQ: http://www.linuxfromscratch.org/lfs/faq.html
>> Unsubscribe: See the above information page

Hi, I had the same issue, albeit with other scripts. The solution was to 
put 'set +h' into the scripts. It seems it's not always enough to have 
it set when entering the chroot environment.

If you type things by hand, there is enough time between the last line 
and the invocation of the next line to have the chroot +h setting 
effect. Not so, when running a script with all lines.

So, in effect, it's a bash issue ;)

Frans.



More information about the lfs-support mailing list