[lfs-support] Test failures in automake-1.12.3 : sorted!

Ken Moffat zarniwhoop at ntlworld.com
Sat Sep 29 16:32:22 PDT 2012

On Mon, Aug 20, 2012 at 11:14:11AM +0100, Ken Moffat wrote:

 (long quotes, for context) -

> On Sun, Aug 19, 2012 at 08:26:39PM -0500, Bruce Dubbs wrote:
> > Ken Moffat wrote:
> > 
> > >   In this case, I'd appreciate your comments (this list will do) on
> > > automake (if you are testing it) - on a completed system, 1.12 and
> > > later give me about 4 errors as a regular user (I'd still like to
> > > get to grips with those, one day).  In a system which boots, but
> > > where I've gone back to chroot, and in my results during regular
> > > chroot, I get more than 80 failures when running the tests as root.
> > > Most of them in t/instspc.tap.
> > 
> > In a jhalfs build I have been testing automake-1.12.3.
> > 
> > # TOTAL: 2823
> > # PASS:  2618
> > # SKIP:  166
> > # XFAIL: 37
> > # FAIL:  2
> > # XPASS: 0
> > # ERROR: 0
> > 
> > And that's with the broken timezones.
> > 
> > FAIL: t/python-missing.sh  (well yes, it's missing)
> > FAIL: t/subdir-add2-pr46.sh ???
> > 
> >    -- Bruce
>  I'm close to giving up on the automake tests.  Last night I had 3
> failures in 1.12.3 - but only once I ran the tests as a user.  I had
> that t/python-missing.sh and assumed it was because Python is
> installed (it's my bootable system, back in chroot).  My other two
> were t/lex-clean-cxx and t/lex-depend-cxx : both undefined reference
> to `yylex'.
>  I suppose those lex tests are SKIP for you, because LFS has not
> installed flex when automake is built.
 First, ISTR that we did something which fixed the lex tests, but I
no longer remember what.  My main problem (multiple failures in
t/instspc.tap) turns out to be because of how my buildscripts work :
I pass $SCRIPTS to point ot the root of the scripts (e.g. for my
general functions for working out the directory name,for writing
the stamp with the SBU calculation, and for logging).
Unfortunately, t/instspc.tap breaks if $SCRIPTS is set!

 There is at least one other place where environment variables have
broken a build for me ($ARCH when set to x86_64 in glibc), so I've
added this to my "don't do that here" list :)

 After all that (about a week of various attempts to fix this), I
was *disappointed* to see that the automake testsuite still failed -
our old friend t/python-missing.sh.  My impression is that the tests
are supposed to skip if a dependency is not installed.  Google did
find something related:

 I've now (at the end of chapter 6 in chroot) rebuilt automake with
that patch and got the following result from the testsuite -

make[3]: Leaving directory `/building/automake-1.12.3'
Testsuite summary for GNU Automake 1.12.3
# TOTAL: 2823
# PASS:  2640
# SKIP:  145
# XFAIL: 38
# FAIL:  0
# XPASS: 0
# ERROR: 0
make[2]: Leaving directory `/building/automake-1.12.3'
make[1]: Leaving directory `/building/automake-1.12.3'
root in chroot /building/automake-1.12.3#

 Unfortunately, the bug report shows the problem was a race, and I'm
not yet convinced that the reported bug was necessarily the same as
what we've been seeing.  So, it worked for me this time, but maybe I
jsut got lucky.

 In a completed system, I *always* have Python installed, so I can
only test this in chroot.  So, the 80+ failures are sorted (at
last!) and I'll open a ticket for this possible fix to
t/python-missing.sh.  Normally, I'd just upload the patch, but I'd
prefer to get confirmation that it fixes the problem.  More on -dev
when I've created a ticket.

das eine Mal als Tragödie, das andere Mal als Farce

More information about the lfs-support mailing list