[lfs-support] Chapter 2.3

William Harrington berzerkula at cox.net
Mon Sep 24 17:32:10 PDT 2012

On Sep 24, 2012, at 19:07 PM, Garrett Gaston wrote:

> On chapter 2.3. Creating a File System I'M told to issue the  
> command "mkswap /dev/<xyz> for initialization purposes.
> The thing is I created and set up my three partitions before  
> starting LFS. sda1 will be my LFS, sda2 is swap, and sda3 is my  
> host system. So how important is this command because when I type  
> it now I'M getting this?:
> "No such file or directory", for sda2. I also tried hda2 and got "/ 
> dev/hda2: Device or resource busy"
> I've already completed the LFS project once but my instructor is  
> insisting that I do it again but use my previous LFS as my host  
> system. For future reference some of you might remember me getting  
> stuck on the LFS project when
> I tried to boot it, can't remember the exact error but I got it  
> resolved and thought I would go ahead and share for anyone else  
> that might ever have the same problem. It was apparently coming  
> from the grub.cfg file, where I had
> sda1 listed, for whatever reason my system or LFS was expecting hda1.
> -- 
> http://linuxfromscratch.org/mailman/listinfo/lfs-support
> FAQ: http://www.linuxfromscratch.org/lfs/faq.html
> Unsubscribe: See the above information page

Hello Garrett,

After creating your partitions, did your system update the block  
devices available? What is your host distro?  Did you reboot after  
doing so if the device nodes weren't updated?


William Harrington

More information about the lfs-support mailing list