[lfs-support] Chapter 2.3

Garrett Gaston garrett85 at hotmail.com
Mon Sep 24 17:07:11 PDT 2012

On chapter 2.3. Creating a File System I'M told to issue the command "mkswap /dev/<xyz> for initialization purposes.
The thing is I created and set up my three partitions before starting LFS. sda1 will be my LFS, sda2 is swap, and sda3 is my host system. So how important is this command because when I type it now I'M getting this?:
"No such file or directory", for sda2. I also tried hda2 and got "/dev/hda2: Device or resource busy"
I've already completed the LFS project once but my instructor is insisting that I do it again but use my previous LFS as my host system. For future reference some of you might remember me getting stuck on the LFS project when 
I tried to boot it, can't remember the exact error but I got it resolved and thought I would go ahead and share for anyone else that might ever have the same problem. It was apparently coming from the grub.cfg file, where I had 
sda1 listed, for whatever reason my system or LFS was expecting hda1. 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20120924/3e1f9883/attachment.html>

More information about the lfs-support mailing list