[lfs-support] glibc-2.16.0 configure error - relro

Thomas Jensen tj at tj-software.dk
Sat Sep 22 09:05:25 PDT 2012


Den 22-09-2012 17:09, Ken Moffat skrev:

>   Look through config.log in 'view' or 'less'.  Find the error
> message 'linker with -z relro support required', then look at the
> lines before that (perhaps a couple of screens) to see what error
> message was produced, probably by gcc or ld.
>

Thanks. That helped! Mawk seems to be the problem.

 From config.log:
mawk: conftest.awk: line 16: function strtonum never defined

First google-hit points to:

http://ubuntuforums.org/showthread.php?t=2024428

and last post suggest:

sudo apt-get install gawk

and that solved the problem.

thomas at zepto:~$ mawk -W version
mawk 1.3.3 Nov 1996, Copyright (C) Michael D. Brennan

thomas at zepto:~$ gawk -W version
GNU Awk 3.1.8



-- 
Thomas Jensen



More information about the lfs-support mailing list