[lfs-support] GCC-4.7.1-Pass 2 MPC configure fails

Richard Melville richard.melville69 at googlemail.com
Mon Sep 24 05:00:55 PDT 2012

> On Wed, Aug 08, 2012 at 07:01:02PM +0100, Richard Melville wrote:
> > I realise that I'm building the dev edition, but my host is Linux Mint
> > Cinnamon 64 bit and the host requirements appeared to fit better. Also it
> > looked as though the dev edition was at a reasonably stable stage.
> >
> > I'm building a 64 bit edition on a 64 bit host (OS and hardware).
> >
> > The failure is:-
> >
> > checking for MPFR... no
> > configure: error: libmpfr not found or uses a different ABI (including
> > static vs shared).
> > make[1]: *** [configure-mpc] Error 1
> > make[1]: Leaving directory `/mnt/lfs/sources/gcc-build'
> > make: *** [all] Error 2
> >
> > Everything has built fine up to this stage and the sanity checks were OK.
> > MPFR and GMP have compiled OK with the libraries installed in .libs. I've
> > even checked to make sure that the MPFR libraries were 64 bit, and now
> I've
> > run out of ideas. I'd be really grateful for any help. I've tried
> > rebuilding GCC four times now with the same result.
> >
> > Richard
>  Richard - since this is still bugging you, I've come back to your
> original post.  I notice one thing which nobody has mentioned:
>  *when* you get this error, look at the *appropriate* config.log
> file [ gcc, like binutils, runs configure in multiple directories].
> Even if this error happens/happened when running 'make', the error
> was within one of the configure scripts - gcc builds everything
> several times, and each time it configures the directories within
> it.
>  Whenever configure fails (I usually point this out for "cannot
> create executables" messages), the key to understanding the problem
> is to find the appropriate config.log file, open that up in 'view'
> (or 'less'), search for 'a different ABI', and then look for the
> error messages in the lines before that.  Probably, an error from
> gcc or ld.
>  Once you have the error message, there are two possibilities:
> 1. it will indicate an error you made, and perhaps be blindingly
> obvious (I've had that when I was building for multiple archs and
> accidentally fell through to passing some ppc-only options in my
> CFLAGS :) - if so, please give the list a brief summary of what
> went wrong so that the next person who eventually does that can
> fix it.
>  or, more likely:
> 2. Something new, which needs to be addressed.  The ABI in the
> message reminds me of a past problem with gmp where, if CFLAGS were
> set, a processor capable of running 64-bit code would default to
> building 64-bit even though the rest of hte build was 32-bit.  But,
> the variability in your results suggests this is not something
> "easy" like that.
Bruce and Ken -- thanks for the replies and apologies for my tardy response.

The fact is that I finished the build a while ago with this problem being
pretty much the only real issue.  I deleted all the packages and files so I
don't have anything to work with in terms of tracking down exactly what
happened.  I've tried rebuilding GCC a couple of times since but I've been
unable to replicate the failure.  I'm fairly certain that it was a bug of
some sort (too many others have reported the same issue) but now I have no
proof.  I realise that without the logs of the failed build it's pointless
discussing the issue, unless. of course, the next person to experience the
problem is willing to share their log files.

Anyway, thanks again for your help.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20120924/b8c921df/attachment.html>

More information about the lfs-support mailing list