[lfs-support] LFS 7.2 GCC pass 1

Tobias Gasser lfs at ebp-gasser.ch
Thu Sep 6 22:12:42 PDT 2012

Baho Utot schrieb:
> I always build all of LFS with -j4 or -j8 and it has not failed me.

so you just had very very much luck on your way...

there are packages which CAN fail with parallel builds.

whenever i run into a problem, i just restart the package with -j1 which
often solved the problem magically in the past...

i'm used to set -jX to the number of cores i have (currently -j8 on my
i7) globally which speeds up the build-time significally.

my system might be a little special, as i use a SSD and the working
diretory for the builds is a tmpfs as i have 16g of ram available. thus
disk-io is very very very fast.

from the base LFS i have to overwrite -j8 for
make grub
make groff
make / test udev
test tar
test patch
test binutils

as i don't check the makeflag on each new version, probably one or
another package meanwile would rund fine with -j8.

for python make and test run fine with -j8, but install requires -j1
(not always, but on rary occasions it fails as files are tried to be
installed into a directory not yet build by another thread)

recently i had intermittent failures on both xulrunner and firefox where
i build with -jX since a very long time. with version 15.0 the build
fails at about half of the builds on my system. giving -j1 runs fine. i
can use 8 cores in the mk_add_options MOZ_MAKE_FLAGS="-j8" but NOT in
the MAKEFLAGS or the make-commandline!


More information about the lfs-support mailing list