[lfs-support] Error in 'make install' of Util-linux-ng-2.16 LFS 6.5

Bruce Dubbs bruce.dubbs at gmail.com
Sun Oct 28 09:51:41 PDT 2012


Ken Moffat wrote:
> On Sun, Oct 28, 2012 at 01:18:09PM +0530, Veena K Vinayan wrote:
>> Host system : Ubuntu 11.10
>>
>> LFS book version 6.5

>   What is it with you people trying to build such an old version of
> LFS using a fairly-recent host system ?
>
>   This looks as if you are using an inadequate shell - I suspect that
> your host system has /bin/sh pointing to dash.  I'm surprised that
> you seem to have ended up with an inadequate build of
> /tools/bin/bash, so I wonder if there is some other error too.  But
> it isn't worth raking over the details.  I very much doubt that
> anyone here has built LFS-6.5 in the last 18 months.  Using 7.2, and
> paying attention to the host system requirements, will be a better
> use of your time.

I agree.  However a new (e.g. LFS-7.1++) system can be bootstrapped from 
a fairly old host (e.g. LFS-6.1--).  See

http://www.linuxfromscratch.org/~bdubbs/files/updating-lfs.html

   -- Bruce



More information about the lfs-support mailing list