[lfs-support] new to lfs, I get a error on glibc configure

软刀 ljy080829 at gmail.com
Fri Oct 26 15:20:58 PDT 2012


a ha, I follow Ken Moffat and Thomas Jensen's talk and solve the problem

Thanks. That helped! Mawk seems to be the problem.

 From config.log:
mawk: conftest.awk: line 16: function strtonum never defined

First google-hit points to:
http://ubuntuforums.org/showthread.php?t=2024428

and last post suggest:

sudo apt-get install gawk

and that solved the problem.

thomas at zepto:~$ mawk -W version
mawk 1.3.3 Nov 1996, Copyright (C) Michael D. Brennan

thomas at zepto:~$ gawk -W version
GNU Awk 3.1.8



2012/10/27 软刀 <ljy080829 at gmail.com>

>
> checking LD_LIBRARY_PATH variable... ok
> checking whether GCC supports -static-libgcc... -static-libgcc
> checking for bash... /bin/bash
> checking for gawk... no
> checking for mawk... mawk
> checking for perl... /usr/bin/perl
> checking for install-info... /usr/bin/install-info
> checking for bison... no
> checking for libc-friendly stddef.h... yes
> checking whether we need to use -P to assemble .S files... no
> checking for .set assembler directive... yes
> checking for assembler gnu_unique_object symbol type... yes
> checking for .symver assembler directive... yes
> checking for ld --version-script... yes
> checking for .previous assembler directive... yes
> checking for .protected and .hidden assembler directive... yes
> checking whether __attribute__((visibility())) is supported... yes
> checking for broken __attribute__((visibility()))... no
> checking for broken __attribute__((alias()))... no
> checking whether to put _rtld_local into .sdata section... no
> checking for .preinit_array/.init_array/.fini_array support... yes
> checking whether to use .ctors/.dtors header and trailer... (cached) yes
> checking for libunwind-support in compiler... no
> checking for -z nodelete option... yes
> checking for -z nodlopen option... yes
> checking for -z initfirst option... yes
> checking for -z relro option... no
> configure: error: linker with -z relro support required
>
> I follow  5.7. Glibc-2.16.0<http://www.linuxfromscratch.org/lfs/view/stable/chapter05/glibc.html>, but get the error on run configure  command, and I find a patch file was
> not used , was this case the problem?
>
> lfs at cpu:/home/yan/lfs/sources/glibc-build$ ls ../glibc-
> glibc-2.16.0/                       glibc-2.16.0.tar.xz
> glibc-2.16.0-res_query_fix-1.patch  glibc-build/
>
>
> thank you
>



-- 
as I learning english, any help about english grammar is welcome
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20121027/1eea6da7/attachment.html>


More information about the lfs-support mailing list