[lfs-support] error while loading shared libraries

Ken Moffat zarniwhoop at ntlworld.com
Wed Oct 24 19:23:24 PDT 2012


On Thu, Oct 25, 2012 at 09:02:48AM +0800, lx wrote:
> 
> Do I adjust the toolchain follow the LFS-BOOK-7.1 ?
> If this way works, I can go on installing the lfs follow the LFS-BOOK-7.2.
> 
> Thank you.

 I'm sorry, I still don't understand.  Let me give you some
background: in LFS-4 we saw a lot of people who had problems that
other people never had.  From that came the "pure LFS" of LFS-5.0
and later which aims to isolate the the final system from whatever
is used to build it.  A major part of that isolation is using the
same versions of the packages in both chapters 5 and 6.

 Mixing instructions from different versions of the book (e.g.
building 7,2, but using some instructions from 7.1) is almost
guaranteed *not* to work : if the instructions changed in a newer
version of the book, it is usually because it was necessary for the
newer versions of the packages.

 I've still not got any idea what you have built to get to your
current problem, but my gut feeling is that you need to start again,
using only the 7.2 book.  Perhaps that is too pessimistic a view,
but you have not provided any details of what you did.

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the lfs-support mailing list