[lfs-support] glibc 2.16.0 don't compile with gcc 4.7.1

Bruce Dubbs bruce.dubbs at gmail.com
Wed Oct 24 10:41:37 PDT 2012


Adrien Vasseur wrote:
> So I have :
>
> bash, version 4.2.37(1)-release
> /bin/sh -> /bin/bash

Don't top post or you will stop getting responses.  Also, trim things 
that are not relevant.

> And it doesn't work :
>
> gcc ../sysdeps/ieee754/dbl-64/wordsize-64/s_isnan.c -c -std=gnu99
> -fgnu89-inline -fno-stack-protector -O2 -Wall -Winline -Wwrite-strings

My log has

x86_64-lfs-linux-gnu-gcc ../sysdeps/ieee754/dbl-64/wordsize-64/s_isnan.c ...

It appears that you have a problem with gcc.

I suggest you start over, ensuring all expanded tarballs and -build 
directories are removed.  Pay close attention to the instructions and 
don't change anything.

   -- Bruce





More information about the lfs-support mailing list