[lfs-support] glibc 2.16.0 don't compile with gcc 4.7.1

Bruce Dubbs bruce.dubbs at gmail.com
Wed Oct 24 10:03:09 PDT 2012


Adrien Vasseur wrote:
> Wow ! Very fast reply !
>
> I run the script in the Host System Prerequisites and I have :
>
> bash, version 4.2.37(1)-release
> /bin/sh -> /bin/dash
> Binutils: (GNU Binutils for Ubuntu) 2.22.90.20120924
> bison (GNU Bison) 2.5
> /usr/bin/yacc -> /usr/bin/bison.yacc
> bzip2,  Version 1.0.6, 6-Sept-2010.
> Coreutils:  8.13
> diff (GNU diffutils) 3.2
> find (GNU findutils) 4.4.2
> GNU Awk 4.0.1
> /usr/bin/awk -> /usr/bin/gawk
> gcc (Ubuntu/Linaro 4.7.2-2ubuntu1) 4.7.2
> (Ubuntu EGLIBC 2.15-0ubuntu20) 2.15
> grep (GNU grep) 2.12
> gzip 1.5
> Linux version 3.5.0-17-generic (buildd at allspice) (gcc version 4.7.2
> (Ubuntu/Linaro 4.7.2-2ubuntu1) ) #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012
> m4 (GNU M4) 1.4.16
> GNU Make 3.81
> patch 2.6.1
> Perl version='5.14.2';
> GNU sed version 4.2.1
> tar (GNU tar) 1.26
> Texinfo: makeinfo (GNU texinfo) 4.13
> xz (XZ Utils) 5.1.0alpha
> gcc compilation OK
>
> So I think it's all correct, no ?

No.   /bin/sh -> /bin/dash is wrong.  dash is known to case problems 
with glibc.

   -- Bruce






More information about the lfs-support mailing list