[lfs-support] video - radeon mesa xv

Walter Webb ngogn at earthlink.net
Sun Oct 14 13:42:36 PDT 2012

When my latest computer was new, I used the fglrx driver for about
three years.  I think the first Xorg driver I could use without
problems was xf86-video-ati-6.14.0.  Since I started using Xorg
drivers, I could no longer use GMplayer, but xine worked ok.

Until recently, I have used Xorg-7.6 with an older MesaLib-7.9.
I do not remember why I used the older Mesa; but when I built
lfs-7.2 and Xorg-7.7, xine's video was no longer adequate.

After some Googling and probing around with slackware-14.0, I found
out several things.  For one thing, to get Xv working, some extra
firmware was required.  If the kernel radeon drivers were compiled
in the kernel, the extra firmware must also be loaded in the kernel.
Otherwise the drivers and firmware must both be loaded at boot time.

There seems to be no way to get Xv without the tiny console font.

GMplayer and xine both work with Xv, but normal response is slow.
Since xine worked before, and I suspected Mesa for some reason,
I copied lfs-7.2 to another partition (I have plenty) and installed
MesaLib-7.9.  I used MesaLib-7.9-add_xdemos-3.patch and had to
install talloc.  I also had to remove an instruction I don't
remember where; some value was saved to a non-existent location.
I reran make; the build completed with no more problems.

Now xine works.  Meanwhile, running top, I noticed that xine uses
almost three times as much cpu time without Xv as it does with it.

Is there any good reason not to use MesaLib-7.9?


More information about the lfs-support mailing list