[lfs-support] LFS-7.2 host system tar version

nettxzl nettxzl at gmail.com
Fri Nov 23 18:38:47 PST 2012


On 11/24/12, William Harrington <berzerkula at cox.net> wrote:
>
> On Nov 23, 2012, at 8:11 PM, nettxzl wrote:
>
>> As I said in my first post, my version of tar is 1.19
>
> What is your HOST OS and output of tar --help ?
>
> Sincerely,
>
> William Harrington.

Ok, I was getting to it. I was in the middle of updating to tar-1.22
on my host system, and it all works fine now with the new tar.

-Jxf workz, -xf works with tar-1.22

I don't use a distro. I've been using LFS/BLFS for 7 years now, and
it's sheer joy to use. I don't think I could ever go back to a distro.

My present LFS/BLFS is based on a hybrid LFS-6.3/SVN version
(SVN-20080412, SVN-20080423)

The tar-1.19 I used, I built following the instructions in
SVN-20080412). And, yes, the md5sum matches the md5sum given in
SVN-20080412. I downloaded it from the link in SVN-200802412.

These are all the packages I used in my LFS system:

linux-2.6.25 API headers
  man-pages-2.78 SVN20080412
  glibc-2.5.1
  binutils-2.17
  gcc-4.1.2
  db-4.5.20
  sed-4.1.5
  e2fsprogs-1.40.8 SVN20080423
  coreutils-6.10 SVN20080412
  iana-etc-2.30 SVN20080412
  m4-1.4.10
  bison-2.3
  ncurses-5.6
  procps-3.2.7
  libtool-1.5.26 SVN20080412
  perl-5.8.8
  readline-5.2
  zlib-1.2.3
  autoconf-2.62 SVN20080423
  automake-1.10.1 SVN20080412
  bash-3.2 SVN20080423
  bzip2-1.0.5 SVN200804012
  diffutils-2.8.1
  file-4.23 SVN200804012
  findutils-4.2.33 SVN20080412
  flex-2.5.35 SVN20080423
  grub-0.97 SVN20080423
  gawk-3.1.6 SVN20080412
  gettext-0.17 SVN20080412
  grep-2.5.3 SVN20080412
  groff-1.18.1.4
  gzip-1.3.12
  inetutils-1.5
  iproute2-2.6.23 SVN20080412
  kbd-1.14.1 SVN20080423
  less-418 SVN20080412
  make-3.81
  man-db-2.5.1 SVN20080412
  module-init-tools-3.4 SVN20080412
  patch-2.5.4
  psmisc-22.6 SVN20080412
  shadow-4.0.18.1
  sysklogd-1.5 SVN20080412
  sysvinit-2.86
  tar-1.19 SVN20080412
  texinfo-4.9
  udev-113
  util-linux-2.12r
  vim-7.1 SVN20080423
  lfs-bootscripts-6.3
  linux-2.6.34.13

I'm afraid I can't give you the output of tar --help from tar-1.19
since I've just now upgraded to tar-1.22 and deleted the previous
install of tar-1.19.

Incidentally, LFS-7.2 will be the 5th LFS system I'm building. My
present LFS/BLFS system is the second full working LFS/BLFS system
that I've built and that I use daily for my work (as I said it's a joy
to use). I've built three complete working LFS systems. I almost
finshed building the fourth (hybrid LFS-6.7/SVN) but it took me so
long, when I got as far as just before installing the bootscripts I
wiped it, and decided to start afresh with 7.2.

Toni



More information about the lfs-support mailing list