[lfs-support] LFS-7.2 host system tar version

nettxzl nettxzl at gmail.com
Fri Nov 23 17:44:42 PST 2012


On 11/24/12, Firerat <firer4t at googlemail.com> wrote:
> On 24 Nov 2012 00:33, "nettxzl" <nettxzl at gmail.com> wrote:
>>
>> (Sorry if this comes through twice. My first attempt seems to have
> vanished.)
>>
>> Hi,
>>
>> I was starting the gcc-4.7.1 (Pass 1) build in Chap. 5 and I was
>> trying to unpack the files compressed with xz following the command
>> given there:
>>
>> tar -Jxf ../mpfr-3.1.1.tar.xz
>>
>> but I got this error message:
>>
>> tar: invalid option -- J
>>
>> I guessed my host system tar is too old, but it is tar-1.19 and this
>> is newer than the minimum version, tar-1.18, stated in the host system
>> requirements.
>> It's not a problem because I can unpack the files in two steps: first
>> with xz, then with tar.
>>
>> But I think you may want to update the tar version in the host system
>> requirements.
>>
>> I checked the tar release info at
> http://www.gnu.org/software/tar/#releases
>>
>> -J was only introduced as a new short option in tar-1.21 as an alias for
> --lzma.
>>
>> And in tar-1.22, the --xz option was introduced to support xz
>> compression, while the short option -J was reassigned as a shortcut
>> for --xz.
>>
>
> I'm not sure when, but at some point tar automagically figures out which
> compression is used so I never use opts for unarchiving, just tar xf  or
> vxf if I fancy some speed reading challenge.
>
> --
> Firerat
>

Yes, I vaguely remember coming across this feature at some point and
it's good to be reminded of it again, but for some reason it does not
work for me with the .xz extension.

I suspect it's because my tar version (1.19), and, consequently, the
minimum version 1.18 in the host system requirements are too old.

Toni



More information about the lfs-support mailing list