[lfs-support] Grub 2.0 problem

William Harrington berzerkula at cox.net
Wed Nov 14 07:38:46 PST 2012


On Nov 14, 2012, at 4:52 AM, Simon Geard wrote:

> On Tue, 2012-11-13 at 14:18 -0500, alex lupu wrote:
>> 2. In general, if grub 0.97 could be used here, does it have  
>> limitations in
>> other complicated configurations, present and in the foreseeable  
>> future?
>
> If I remember correctly, grub1 can't be built on a 64-bit system. That
> is, it can boot one just fine, but it can't be compiled without  
> using a
> 32-bit compiler.
>
> Simon.
> -- 
> http://linuxfromscratch.org/mailman/listinfo/lfs-support
> FAQ: http://www.linuxfromscratch.org/lfs/faq.html
> Unsubscribe: See the above information page

Grub 2.00 can be built with ppc, sparc, sparc64, x86, x86_64, and  
others.
Same with Grub 1.9x as well.  I had 1.98 working out of he box with  
sparc64 and not using SILO.

Sincerely,

William Harrington



More information about the lfs-support mailing list